Opened 13 years ago

Closed 13 years ago

#2701 closed defect (fixed)

FOA: Scroll effect glitch

Reported by: eriktorbjorn Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 4

Description

Latest 0.9.0 SVN
English talkie version

Before reaching the center of Atlantis, there's a brief
cutscene, that ends with a scroll down effect. Just
before the effect starts, the screen is blanked. We had
a similar problem in Fatty Bear's birthday surprise,
but that has supposedly been fixed now.

I've attached a savegame. Simply walk off the screen to
the right.

Ticket imported from: #1509006. Ticket imported from: bugs/2701.

Attachments (2)

atlantisa.s45 (35.3 KB ) - added by eriktorbjorn 13 years ago.
Savegame near glitch
moveScreen.txt (6.8 KB ) - added by Kirben 13 years ago.
moveScreen patch

Download all attachments as: .zip

Change History (5)

by eriktorbjorn, 13 years ago

Attachment: atlantisa.s45 added

Savegame near glitch

comment:1 by Kirben, 13 years ago

This is caused by my change, to fix that similar issue in
fbear.

I really think we need to restore the original method to
moving screen when scrollEffect is used, to cover all cases
but make it SCUMM engines specific this time.

comment:2 by Kirben, 13 years ago

I have attached patch to revert scrollEffect() back to the
original method, using the move_screen() function from SDL
backend.

The method used for _scrollBuffer is too unreliable, since
the screen can change, between _screenBuffer been set and
scrollEffect() been called.

by Kirben, 13 years ago

Attachment: moveScreen.txt added

moveScreen patch

comment:3 by Kirben, 13 years ago

Owner: set to Kirben
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.