Opened 14 years ago

Closed 13 years ago

Last modified 13 years ago

#2613 closed defect (fixed)

KYRA1: Overlapping menu text in spanish version

Reported by: jvprat Owned by: vinterstum
Priority: normal Component: Engine: Kyra
Keywords: Cc:
Game: Kyrandia 1

Description

This bug has been present in the svn snapshots since
the call for testing for kyrandia appeared (didn't test
it with older snapshots), but I had no time to report
it before.

I use the Spanish floopy version of the game.

If I skip the intro, I can see the down part of
Brandon's house (I don't know if I should see it or the
menu), but it crashes immediately with this assertion:

scummvm-20060523_stripped: engines/kyra/gui.cpp:423:
void Kyra::KyraEngine::setGUILabels(): Assertion
`offset + 27 < _guiStringsSize' failed.

If I don't skip the intro, I can begin playing, but if
I click the "Options" button, I get the same assert.

Apart from that and some graphic glitches (with items
and actors), I can play quite well, thanks for your work!

Ticket imported from: #1493774. Ticket imported from: bugs/2613.

Attachments (4)

dump (1.2 KB ) - added by jvprat 13 years ago.
main.png (78.5 KB ) - added by jvprat 13 years ago.
quit.png (89.9 KB ) - added by jvprat 13 years ago.
controls.png (70.3 KB ) - added by jvprat 13 years ago.

Download all attachments as: .zip

Change History (20)

comment:1 by jvprat, 14 years ago

Summary: Asserts in the spanish versionKYRA1: Asserts in the spanish version

comment:2 by lordhoto, 14 years ago

Owner: set to vinterstum

comment:3 by lordhoto, 14 years ago

Maybe you could specify which graphics glitches you mean? We
don't know of any...

I guess the kyra.dat file is broken for spanish version.
Assigned to vinterstum, he does all that stuff.

comment:4 by vinterstum, 13 years ago

Are you able to compile ScummVM from sources yourself? I
know what the problem is, but I need your help to fix it :)
(since I don't have the spanish version myself)

Basically, edit scummvm/engines/kyra/gui.cpp, go to line
488, which looks like this:

/*
for (int i = 0; i < _guiStringsSize; i++)
debug("GUI string %i: %s", i, _guiStrings[i]);

for (int i = 0; i < _configStringsSize; i++)
debug("Config string %i: %s", i, _configStrings[i]);
*/

Remove the /* and */ lines. Then run ScummVM again and start
Kyra, and copy'n' paste the output that appears.

Thanks :).

comment:5 by jvprat, 13 years ago

I attach the output in the attached file. There are a lot of
characters I can't read, so I redirected it to a file. Which
encoding does it use? :S

By the way, I'll now fill a few bugs about the graphic
glitches I said before.

Thanks for your effort and support! :)

comment:6 by jvprat, 13 years ago

Oops, I forgot to upload the file. Here it is.

by jvprat, 13 years ago

Attachment: dump added

comment:7 by vinterstum, 13 years ago

Resolution: fixed
Status: newclosed

comment:8 by vinterstum, 13 years ago

Great, thanks :)

The problem actually wasn't what I thought it was, but it
should be fixed now anyway.

The problem was indeed in kyra.dat, so you'll need to
download a fixed version.

comment:9 by jvprat, 13 years ago

It still breaks here. I've recompiled it from svn, I've
updated kyra.dat (md5: c541c43f7b956c7b9a64e5acec656fb0) and
I've removed and readded the game in the main menu, but it
still breaks with the same sympthoms. Should I do something
more?

Thanks!

comment:10 by vinterstum, 13 years ago

Aha, looks like there were some additional issues with it :).

They should be fixed now. However, the only way I had of
testing stuff was tricking scummvm into thinking my english
floppy version was the spanish one, so please report back
:). Specifically, is there a lot of text overlap in the
configuration menu?

by jvprat, 13 years ago

Attachment: main.png added

comment:11 by jvprat, 13 years ago

Yay! I can now skip the intro and access the menus! Thanks :D

There are a few overlapings. I've thought of using dosbox to
see the original placing. In the attached screenshots you
can see the difference between scummvm (left) and dosbox
(right).

Thanks for your work!

by jvprat, 13 years ago

Attachment: quit.png added

by jvprat, 13 years ago

Attachment: controls.png added

comment:12 by sev-, 13 years ago

However word wrap is completely unrelated bug.

jvplat if you would submit it separately, that would be
really nice, from the other hand, vinterstum, you may reopen
this report and change the description.

comment:13 by vinterstum, 13 years ago

Done :)

comment:14 by vinterstum, 13 years ago

Resolution: fixed
Status: closednew
Summary: KYRA1: Asserts in the spanish versionKYRA1: Overlapping menu text in spanish version

comment:15 by vinterstum, 13 years ago

The text alignment should work better now.

comment:16 by vinterstum, 13 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.