Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#2548 closed defect (fixed)

SIMON1: Game Detection fails

Reported by: SF/jim_banks Owned by: sev-
Priority: normal Component: Engine: AGOS
Keywords: Cc:
Game: Simon the Sorcerer 1

Description

Hi,

Simon The Sorceror 1 game detection fails when adding the game via
the GUI. This seems to happen on both 0.8.2 and the current SVN
source snapshot. I'm pretty sure it was working for 0.7.1 and possibly
0.8.0 but I'm not sure about other versions of ScummVM.

I'm using Mac OS X 10.3.9 but someone else on the forums has
confirmed that it fails to be recognised.

Thanks,

Jimbob

Ticket imported from: #1458388. Ticket imported from: bugs/2548.

Change History (14)

comment:1 by SF/jim_banks, 14 years ago

Summary: Simon 1 Game Detection failsSIMON1: Game Detection fails

comment:2 by sev-, 14 years ago

From your post on our forums:

I've checked my datafiles and I have the right files except
SIMON.WAV is SIMON.OGG. I think I have the Windows version
but can't double check because I don't have my CD with me.

Which version is that? Windows? Which language?

comment:3 by SF/jim_banks, 14 years ago

As far as I know it's the English US/Windows/CD version. It came in a
twinpack with Simon 2 and that's detected and reported as the English US/
Windows/CD version. Apologies for missing that off the original submission.

comment:4 by SF/jim_banks, 14 years ago

As far as I know it's the English US/Windows/CD version. It came in a
twinpack with Simon 2 and that's detected and reported as the English US/
Windows/CD version. Apologies for missing that off the original submission.

comment:5 by (none), 14 years ago

Confirmed, for latest SVN snapshot, but not for 0.8.2

Taken from the scummvm.ini (added with 0.8.2 AmigaOS4 build)

[simon1]
description=Simon the Sorcerer 1 (English Windows CD) (English (US)/Windows)
gameid=simon1
language=en
path=Games:ScummVM/Games/Simon/
platform=windows

comment:6 by (none), 14 years ago

Ack, damn, should have test it before submitting

Simon 2 detection is broken too (works in 0.8.2)

Taken from scummvm.ini (added with 0.8.2 AmigaOS4 build)

[simon2]
description=Simon the Sorcerer 2 (English Windows CD) (English (US)/Windows)
gameid=simon2
language=en
path=Games:ScummVM/Games/Simon2/data/
platform=windows

comment:7 by sev-, 14 years ago

Please, provide md5s.

For Simon1:
gamepc
icon.dat
simon.gme
stripped.txt
tbllist

For Simon2:
gsptr30
icon.dat
simon2.gme
stripped.txt
tbllist

comment:8 by sev-, 14 years ago

Also please, provide debug output from the console when you
try to add game. Today I fixed it a bit, so it produces more
readable game titles now.

You need to specify -d2 at command line to get more debug
messages.

comment:9 by (none), 14 years ago

OK... :-)

For Simon1:
d22302abf44219f95d50f2faa807dd1a GAMEPC
4184de25c7a3f4cbabf7b7af0691b093 ICON.DAT
3cd1632bb79ad45619c569ff396bccdb simon.gme
a27e87a9ba21212d769804b3df47bfb2 STRIPPED.TXT
d198a80de2c59e4a0cd24b98814849e8 TBLLIST

For Simon2:
bd85a8b5135592ada9cbeae49160f1d3 gsptr30
ee92d1f84893195a60449f2430d07285 ICON.DAT
a03bd98fca6f60b30300ce56a4363d77 simon2.gme
e229f84d46fa83f99b4a7115679f3fb6 STRIPPED.TXT
2082f8d02075e590300478853a91ffd9 TBLLIST

Debug with -d2 (Sorry, that's all, btw, the new theme
IS displayed correctly despite these "warnings"!)

This output goes for both games:

11.Games:ScummVM> ScummVM_cvs -d2
Debuglevel (from command line): 2
File default-theme.ini not found
File dialog_bkgd_corner.bmp not found
File dialog_bkgd_top.bmp not found
File dialog_bkgd_left.bmp not found
File dialog_bkgd.bmp not found
File widget_bkgd_corner.bmp not found
File widget_bkgd_top.bmp not found
File widget_bkgd_left.bmp not found
File widget_bkgd.bmp not found
File checkbox_empty.bmp not found
File checkbox_checked.bmp not found
File widget_arrow.bmp not found
File widget_small_bkgd_corner.bmp not found
File widget_small_bkgd_top.bmp not found
File widget_small_bkgd_left.bmp not found
File widget_small_bkgd.bmp not found
File button_bkgd_corner.bmp not found
File button_bkgd_top.bmp not found
File button_bkgd_left.bmp not found
File button_bkgd.bmp not found
File logo.bmp not found

comment:10 by SF/jim_banks, 14 years ago

This is the output from 0.8.2 using the -d2 from the CLI for Simon 1: -

Debuglevel (from command line): 2
MD5s of your game version are unknown. Please, report following data to
ScummVM team along with your game name and version:
ICON.DAT: 22107c24dfb31b66ac503c28a6e20b19
SIMON.GME: b1b18d0731b64c0738c5cc4a2ee792fc
STRIPPED.TXT: a27e87a9ba21212d769804b3df47bfb2
icon.dat: 22107c24dfb31b66ac503c28a6e20b19
simon.gme: b1b18d0731b64c0738c5cc4a2ee792fc
stripped.txt: a27e87a9ba21212d769804b3df47bfb2

Using md5sum from the CLI gives me the following values (again for Simon
1): -

d22302abf44219f95d50f2faa807dd1a GAMEPC.
4184de25c7a3f4cbabf7b7af0691b093 ICON.DAT
3cd1632bb79ad45619c569ff396bccdb SIMON.GME
a27e87a9ba21212d769804b3df47bfb2 STRIPPED.TXT
d198a80de2c59e4a0cd24b98814849e8 TBLLIST.

comment:11 by sev-, 14 years ago

Owner: set to sev-
Resolution: fixed
Status: newclosed

comment:12 by sev-, 14 years ago

d22302abf44219f95d50f2faa807dd1a GAMEPC.
d198a80de2c59e4a0cd24b98814849e8 TBLLIST.

That's the reason. Note trailing dots. Fixed in SVN.

comment:13 by SF/jim_banks, 14 years ago

Thanks for that. I think the trailing dot appeared when copying the files off
the DOS (FAT file format) CD. All of my SFX00* files have the trailing dot as
well, should I remove them?

It now works in 0.8.2 but the latest SVN crashes with the following messages
output to the console: -

Looking for simon1
Trying to start game 'Simon the Sorcerer 1'
addDefaultDirectory is called too late. Move all calls to engine constructor!

I never know whether you want bug reports for the latest work in progress
builds.

comment:14 by sev-, 14 years ago

> addDefaultDirectory is called too late. Move all calls to
> engine constructor!
This was already fixed yesterday, please update SVN.

Though in the future, please, use sepatate bugreports for
different issues.

Note: See TracTickets for help on using tickets.