Opened 13 years ago

Closed 13 years ago

#2545 closed defect (fixed)

KYRA1: Actors speech is cut off

Reported by: (none) Owned by: vinterstum
Priority: normal Component: Engine: Kyra
Keywords: Cc:
Game: Kyrandia 1

Description

ScummVM 0.9.0svn (Mar 22 2006 07:02:41)
Features compiled in: Vorbis FLAC MP3 zLib MPEG2

Malcoms speech in the intro is cut. The first parts are
played correctly but the last words are swallowed by
the actors (Malcom, Brandon and his grandfather).

English CD (Speech) version

AmigaOS4 build (GCC 3.4.4)

Ticket imported from: #1455876. Ticket imported from: bugs/2545.

Change History (8)

comment:1 Changed 13 years ago by fingolfin

Owner: set to lordhoto

comment:2 Changed 13 years ago by lordhoto

Hmm.. I can't reproduce that overe here.
But you should know that if you press a mouse button or '.'
in the intro fast mode is activated, then the speech is cut
if a nother one starts before finishing the old one.
If that was the case this is no bug but a feature :),
if not I need to check it again.

comment:3 Changed 13 years ago by (none)

I see...tested with the latest (today) snapshot

Now i have a problem and a feature request

1. The problem:
On Amiga here, i have to "activate" ScummVM's window/screen
by pressing the mouse button once (to actually be able to
use the mouse inside the game windows/screen.

It seems ScummVM's KYRA engine (or maybe all engines)
interprets this intial mouse click as "User wants Fast-Mode"
by mistake, but it isn't intended.

2. The request:
Could the "Mouse click in intro turns on Fast-Mode" be turned
off (somehow). You still have the "." feature to trigger the
Fast-Mode and IMHO, it's a "Point and Click" adventure and
nothing else than anything related to gameplay should be
triggered by a mouse click.

I Hope i found the right words to explain myself

Thanks Johannes

comment:4 Changed 13 years ago by lordhoto

ok I'll assign it then to vinterstum, since he worked on
that stuff.

comment:5 Changed 13 years ago by lordhoto

Owner: changed from lordhoto to vinterstum

comment:6 Changed 13 years ago by lordhoto

Summary: KYRA: Actors speech is cut offKYRA1: Actors speech is cut off

comment:7 Changed 13 years ago by vinterstum

Resolution: fixed
Status: newclosed

comment:8 Changed 13 years ago by vinterstum

We actually fixed this a while ago, just forgot to close the
bug rep at the time I guess :).

Thanks!

Note: See TracTickets for help on using tickets.