Opened 14 years ago

Closed 12 years ago

Last modified 12 years ago

#2467 closed defect (fixed)

KYRA1: GFX problems with ITALIAN floppy

Reported by: SF/gourry Owned by: athrxx
Priority: normal Component: Engine: Kyra
Keywords: Cc:
Game: Kyrandia 1

Description

Version: ScummVM 0.9.0CVS (Jan 18 2006 22:54:33)
Language: ITALIAN
Version: Floppy

First let me repory MD5 of my game (hope can help)
Unknown MD5 (ef08c8c237ee1473fd52578303fc36df)!

The graphical problem is heavy: the inventory is not
shown (but it's there, as wou can get and place
items) and some magenta-looking arrows are dispayed
in the upper-left corner of the screen (see attached
screenshot)

The textual problem is: English text in the
introduction (I remember it was italian) and english
text on the "action line", (like "dropped something")
while talking is in Italian

Hope this can help
Best Regards

Ticket imported from: #1409244. Ticket imported from: bugs/2467.

Attachments (1)

KyraProblems.jpg (186.0 KB ) - added by SF/gourry 14 years ago.
Screenshot of first room

Download all attachments as: .zip

Change History (20)

by SF/gourry, 14 years ago

Attachment: KyraProblems.jpg added

Screenshot of first room

comment:1 by lordhoto, 14 years ago

Owner: set to lordhoto

comment:2 by lordhoto, 14 years ago

Summary: KYRA: Graphical and textual problems with ITALIAN floppy verKYRA: GFX problems with ITALIAN floppy

comment:3 by lordhoto, 14 years ago

Hi,

yeah that is 'normal' since atm we do not have support for
the italian version. I will take a look at this.

comment:4 by lordhoto, 14 years ago

One little question... there must be a MAIN_*.CPS file in
the directory, could you please give me the exact name? If I
have it I could at least make the interface visible, but
still some strings would be english.

comment:5 by SF/gourry, 14 years ago

Yeah, that file is named
MAIN_ITA.CPS

Maybe I can help a bit more... I think that i cannot post
any of the game files for copyright reason but, if you
explain me or provide some sort of tool, I could be able
to extract resources to be put into KYRA.DAT to support
italian version too...

comment:6 by lordhoto, 14 years ago

ok at least the interface and the picture in the intro
should show up now. Our tool to extract the data from the
original executable has no support for other languages than
those we support atm, the problem is that we would need the
offsets of the hardcoded data in the executable and the
executable to extract the data (and before to check for the
offsets).

comment:7 by SF/gourry, 14 years ago

Yeah, they shows up corectly now! Sorry for the delay but
it's about a week that I cannot download snapshot for
windows (it's too slow)... At the end I downloaded it via
scp from sourceforge shell server ;-)

I tried to HEX-EDIT main.exe file and found where strings
are stored. If you provide me some kind of
information/documentation I can extract them and maybe
pack in a format suitable for scummvm.

comment:8 by lordhoto, 14 years ago

I'll see what I can do for a documentation, I will tell you
know if I got anything you can work with.

comment:9 by SF/gourry, 14 years ago

okay, i'll wait...

comment:10 by lordhoto, 14 years ago

Summary: KYRA: GFX problems with ITALIAN floppyKYRA1: GFX problems with ITALIAN floppy

comment:11 by sev-, 14 years ago

What is the status of this item?

comment:12 by SF/gourry, 14 years ago

I'm still waiting for any kind of documentation (format of
kyra.dat, maybe the src of the extractor tool used for
english language...)

comment:13 by fingolfin, 13 years ago

Lordhoto, any news on this one? Do you need anything in particular from the submitter to proceed with this?

comment:14 by lordhoto, 13 years ago

Well I'm working on an tool for our tools package for creating kyra.dat,
if that's finished he could try getting all the file offsets and extract the
data from the main executable.

comment:15 by fingolfin, 12 years ago

What is the status of this item?

comment:16 by lordhoto, 12 years ago

No update, I still don't have an Italian floppy version nor did anyone supply offsets for the text strings from the main executable and the extracted data. Without that it's not possible to 'fix' it a.k.a. adding support for Kyra1 Italian floppy.

comment:17 by SF/gourry, 12 years ago

Using an HEX editor i can clearly distinguish text strings in the main executable and find their offset... If you explain me what I should look for and how the extracted data should be packaged in kyra.dat file I can try to extract them...

comment:18 by athrxx, 12 years ago

I have now added support for Italian floppy.

comment:19 by athrxx, 12 years ago

Owner: changed from lordhoto to athrxx
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.