Opened 13 years ago

Closed 12 years ago

#2367 closed defect (duplicate)

BASS: Game hangs towards the end

Reported by: SF/ryancassar Owned by: lavosspawn
Priority: normal Component: Engine: Sky
Keywords: Cc:
Game: Beneath a Steel Sky

Description

ScummVM version (scummvm -v)
0.8 stable release

Bug details, including instructions on reproducing
Basically, it seems if you delay going into LINC-SPACE to get the virus till
after giving Joey his new android shell, things in LINC-SPACE break
horribly. Music however continues fine, and I can access the menu via F5
and such. Trying to use the Divine Wrath to eliminate the crusader made
the above described crash occur. After reverting to a saved game before
getting Joey's card, and proceeding as before, everything was happy and I
finished the game. By the by, I had first experienced the bug when I was
trying to blind the eyeball to move out of the breifcase room as Gallagher.
I lost the saved game to reproduce this behavious however.

Language of game (English, German, ...)
English

Version of game (Talkie, Floppy, ...)
cd 1.2

Platform and Compiler (Win32, Linux, ...)
OS X binary

Attach a save game if possible
I did

If this bug only occured recently, please note the last version without the
bug, and the first version including the bug. That way we can fix it
quicker by looking at the changes made.
First time using Scummvm!

Ticket imported from: #1358854. Ticket imported from: bugs/2367.

Attachments (1)

SKY-VM.000 (16.2 KB) - added by SF/ryancassar 13 years ago.
Buggy Wrath

Download all attachments as: .zip

Change History (13)

Changed 13 years ago by SF/ryancassar

Attachment: SKY-VM.000 added

Buggy Wrath

comment:1 Changed 13 years ago by joostp

Summary: Game hangs towards the endBASS: Game hangs towards the end

comment:2 Changed 13 years ago by (none)

Mac 0.8.0a (attached some new files)

Yes, according with the savegame it's true. Trying to use the Divine Wrath on
the crusader, 5 times on 6 the animation does not work correctly and the
game freeze (i don't know about the other errors, give more details if
possibile). Unfortunately the Mac version has not the console to see the error
and strangely the mac savegames for this game are different from the
windows ones (so i cannot try the same thing on a win cvs: but tell me if there
is another way, please). However note that the inventory is not in line with the
game progress time, according to me of course.

comment:3 Changed 13 years ago by (none)

sorry, of course i cannot attach anything.. eheh

comment:4 Changed 13 years ago by (none)

Ah, nothing, the savegame problem was only an error of mine. So, on the win
cvs there is the same freeze, but no errors in the console.

bye

comment:5 Changed 13 years ago by fingolfin

guybrushvm, all savegames should always be fully exchangeable between Mac
ScummVM and e.g. Windows ScummVM (provided they are for the precise same
game -- e.g. Sky CD on both systems). If that is not the case for you, please file
a bug report (and ideally, attach a savegame from each system to help analyze
the problem).

comment:6 Changed 13 years ago by (none)

Yes, in fact, i told that was a mine error.

However remain the problem of Ryan. Try the savegame, you should
understand. Seems quite simple to reproduce.

Bye.

comment:7 Changed 13 years ago by fingolfin

Owner: set to lavosspawn

comment:8 Changed 13 years ago by fingolfin

Oops, I missed your last comment, sorry for that.

comment:9 Changed 13 years ago by sev-

What is the status of this item?

comment:10 Changed 12 years ago by bluegr

If I understand correctly, this bug seems to be the same as bug [ 1314495 ] BASS: "game frozen" / "actor stuck" / "Invalid Mode(16)", as they both look quite similar

comment:11 Changed 12 years ago by SF/ryancassar

Confirmed, the bug described there matches what I experienced, in a different part of the game. I would tend to support all the claims made in bug report 1314495, it does appear to be a sloppy scripting code in-game. Apologies for the duplicate bug report.

comment:12 Changed 12 years ago by sev-

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.