Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#2327 closed defect (fixed)

BS1: Scrolling regression

Reported by: eriktorbjorn Owned by: lavosspawn
Priority: normal Component: Engine: Sword1
Keywords: Cc:
Game: Broken Sword 1

Description

The complete discussion of this bug can be found at
http://forums.scummvm.org/viewtopic.php?t=30

It appears that the rather lengthy in-engine cutscene
near the end of the game handles scrolling a bit
unusually: It sets the SCROLL_FLAG variable to 0,
presumably to keep the screen from scrolling.

The problem is that we assume that SCROLL_FLAG = 0
means that the scene is exactly 640x400. And ever since
revision 1.47 of sword1/screen.cpp we ever reset the
SCROLL_OFFSET variables to 0 in this case. So the
overhead view of Nico and George looking down at the
neo-Templars always shows the leftmost part of it, even
though the room is wider than that.

The effect is subtle, which is probably how it has
remained unnoticed for almost a year.

Ticket imported from: #1345130. Ticket imported from: bugs/2327.

Change History (3)

comment:1 by eriktorbjorn, 14 years ago

Owner: set to lavosspawn

comment:2 by lavosspawn, 14 years ago

Okay, fixed it.
It may cause other problems though and needs testing, so I
won't add the fix to the 0.8.0 branch for now.

comment:3 by lavosspawn, 14 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.