Opened 14 years ago

Closed 7 years ago

#2241 closed defect (fixed)

MI2 VGA: Part of the music seems to die intermittently

Reported by: SF/dfabulich Owned by:
Priority: low Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 2

Description

At apparently random intervals, part of the music, but
not all of the music, seems to die off. I can't find a
perfectly reliable way to reproduce this. (It looks a
lot like bug 1315950... I was tempted to just confirm
it as a duplicate, but I figured I'd file it separately
and let the developers decide whether it's a real bug
or not.)

I've attached a save game that seems to nearly reliably
reproduce it. It's just as you're falling into the
underground tunnels near Big Whoop. Feel around for
the light switch and then Use it. Click through the
conversation with LeChuck and eventually you'll be on
your own, but the music will be almost silent; you'll
hear a little percussion or a couple of instruments in
the background, but not the full ensemble. (This
doesn't happen every time, though! :-p)

I'm using MI2 VGA Floppy with Windows XP, ScummVM
0.8.0CVS (Oct 11 2005 19:21:40). Features compiled in:
Vorbis FLAC MP3 zLib MPEG2

Ticket imported from: #1324103. Ticket imported from: bugs/2241.

Attachments (2)

monkey2.s04 (25.2 KB ) - added by SF/dfabulich 14 years ago.
save as you're falling into the tunnels.
monkey2.s02 (33.1 KB ) - added by SF/dfabulich 14 years ago.
Oct 18 - leave Woodtick, all music stops

Download all attachments as: .zip

Change History (16)

by SF/dfabulich, 14 years ago

Attachment: monkey2.s04 added

save as you're falling into the tunnels.

comment:1 by sev-, 14 years ago

Yet another iMUSE bug. Lowering priority until we have
someone with time to dig into iMUSE.

comment:2 by sev-, 14 years ago

Priority: normallow

comment:3 by eriktorbjorn, 14 years ago

Or it could be that pitch wheel change I made. I've changed
it - again - so that it only centers the pitch wheels on
unload if the engine has specifically asked for it. Could
you try the next ScummVM snapshot and see if you can still
reproduce the bug?

comment:4 by SF/dfabulich, 14 years ago

That apparently seemed to fix my "nearly reproducible" save.
I'll do another run through soon to see if it crops up
again (since the problem was occurring unpredictably).

comment:5 by eriktorbjorn, 14 years ago

Any news about this?

comment:6 by SF/dfabulich, 14 years ago

I plan to do another run through tomorrow.

comment:7 by SF/dfabulich, 14 years ago

Today's CVS seems mostly better, but not all the way. Music
transitions (e.g. on Scabb moving from room to room) seem a
little flakey... hard to reproduce reliably (it's more
frequent if you play in fast mode, so I tried hard to get it
to happen at normal speed), but I've attached one save
towards endgame that always works. Load up the save and
leave Woodtick; ALL the music will cut out. It will return
when you go somewhere else (e.g. swamp.) Using ScummVM
0.8.0CVS (Oct 16 2005 19:58:34), Features compiled in:
Vorbis FLAC MP3 zLib MPEG2.

by SF/dfabulich, 14 years ago

Attachment: monkey2.s02 added

Oct 18 - leave Woodtick, all music stops

comment:8 by eriktorbjorn, 14 years ago

Well, fast mode is documented in the README as being not
entirely reliable...

comment:9 by eriktorbjorn, 14 years ago

In this particular savegame, it's already playing the wrong
music - the music for one of the houses (Wally's?) - rather
than the outdoors music. That's probably what's confusing it
when you leave town.

Anyway, unless the problems also happen at normal speed, I
don't think it's a ScummVM bug really. It's probably more a
case of stressing the iMUSE system in ways it wasn't meant
to be stressed.

comment:10 by SF/dfabulich, 14 years ago

It absolutely does happen when not in fast mode. In the
provided Oct 18 save game, I made sure that I never used
Fast mode in the entire game, and never pressed ESC to skip
anything (I did make ample use of '.' to accelerate
dialogue, but that's it).

Fast mode makes it easier to reproduce, but I think the
point is that iMuse will randomly (infrequently) hiccup, and
that Fast mode is a good way to stress it to highlight the
error.

comment:11 by lordhoto, 8 years ago

We had some changes to the iMuse part priority code recently, might this be related?

comment:12 by athrxx, 8 years ago

If this is the same as #1315950 then it should be fixed.
We did have a regression from another bug fix which sometimes caused certain sound commands to get removed from the command queue without being executed.

comment:13 by fuzzie, 7 years ago

Resolution: fixed
Status: newclosed

comment:14 by fuzzie, 7 years ago

I'm just going to close this as hopefully-fixed since it's been more than two years. Feel free to complain loudly if you disagree!

Note: See TracTickets for help on using tickets.