Opened 14 years ago

Closed 14 years ago

#2192 closed defect (worksforme)

PSP: Crash at very beginning of Game (The Dig)

Reported by: SF/macmoll Owned by: joostp
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: The Dig

Description

Using latest beta5 and playing _german_ version of the
"The Dig" using a PSP 1.0, I have a blue-screen crash
at the beginning of the game where "Commander Low" and
two other crew members first go down into the asteriod
and detect the alien metal plates.

I get this info:

Execption: Bus error (data)
EPC: 08B9987C
Cause: 1C
Status: 20008603
BadVAddr 0000000

Thanks for a fix.

Ticket imported from: #1287976. Ticket imported from: bugs/2192.

Attachments (1)

dig.s01 (10.8 KB ) - added by SF/macmoll 14 years ago.
Save game before crash location

Download all attachments as: .zip

Change History (20)

comment:1 by SF/macmoll, 14 years ago

Summary: Blue-Screen Crash at very beginning of Game...PSP: Blue-Screen Crash at very beginning of Game...

comment:2 by joostp, 14 years ago

Owner: set to joostp
Summary: PSP: Blue-Screen Crash at very beginning of Game...PSP: Crash at very beginning of Game (The Dig)

comment:3 by joostp, 14 years ago

I haven't played The Dig much, please provide some more
details on reproducing and possibly a savegame.

Also, have you verified it doesn't happen with a daily
snapshot build on windows / your OS of choice?

by SF/macmoll, 14 years ago

Attachment: dig.s01 added

Save game before crash location

comment:4 by SF/macmoll, 14 years ago

Load the provided savegame and continue with gameplay by
clicking on the "stones" and the "metal plate" to trigger
the next dialog sequence. Game crashes at end of this
sequence with indicated error.

__BUT__: It's not 100% reproduceable (sorry!). I tried this
multiple times, and crash happens only sometimes - perhaps
when some sound "artifacts" are audible.

comment:5 by SF/macmoll, 14 years ago

Sorry, never tried ScummVM on native windows to verify this
crash. Should I?

comment:6 by joostp, 14 years ago

Please do, using the exact same set of datafiles.

comment:7 by SF/macmoll, 14 years ago

Sorry, but I cannot load my PSP savegame from PSP beta5 into
the windows binary of ScummVM version 0.7.1...

But the crash in the PSP version is still there: Using the
provided savegame, just try to examine the "metal plate" and
al things around again and again (mutiple times). In this
situation, I get this blue-screen crash.

From my windows programming experience: Isn't there any
stack frame (debug version?) for further inspection?

comment:8 by joostp, 14 years ago

I don't own a large enough memory stick to run The Dig at
the moment so I haven't tried reproducing it with my english
version yet.

The PSP version is based on current 0.8.0CVS source, so the
savegame won't work with 0.7.1.
You can, however, download a CVS build for windows from the
downloads page that should load the PSP savegames just fine.

Note that you should always verify bugs against the CVS
version of ScummVM.
The reason I want you to do this is to find out if it's my
responsibility or that of the SCUMM engine maintainer(s).

Btw, I did play around with a demo version of The Dig but
couldn't get that one to crash.

comment:9 by SF/macmoll, 14 years ago

Issue was not reproducable on win32 verson.

Anyways, this seems to be related to audio issues. For
example, if frame rate drops, audio begins to stutter. Then,
chances are high that one of the two cases happen:
(1) I get the mentioned blue-screen crash
(2) Game hangs (new observation)

Especially case (2) reminds me to a programming issues where
audio buffers run dry and get not refilled in time, becasue
of lost/missing timing/interrupts etc. pp.

But this stuttering is still in the game.

Sorry, for not getting more details about this.

comment:10 by joostp, 14 years ago

Interesting...

Can you please try this unstripped build, and give me the
details from the exception screen when it crashes?
http://0x.7fc1.org/psp/scummvm/EBOOT.PBP

comment:11 by SF/macmoll, 14 years ago

Using the provided EBOOT.PBP, these are the details of the
latest crash:
Excpetion: Address store
EPC: 08BADBE0
Cause: 00014
Status: 20008603
BadVAddr 837F7A85

comment:12 by sev-, 14 years ago

Priority: normalhigh

comment:13 by sev-, 14 years ago

This seems like a release critical. Raising priority.

comment:14 by joostp, 14 years ago

I can't reproduce this with my english version.

comment:15 by sev-, 14 years ago

Priority: highnormal

comment:16 by sev-, 14 years ago

Ok, after discussion, I'm lowering priority for it. Problem
is that joostp doesn't have the game so that can't be fixed
in nearest future.

comment:17 by joostp, 14 years ago

I'd be interested to hear if this is fixed in 0.8.0 or not.

comment:18 by joostp, 14 years ago

Resolution: worksforme
Status: newclosed

comment:19 by joostp, 14 years ago

Closing due to a lack of response of the submitter and the
inability for me to reproduce it here with the English
version and latest ScummVM source, that old 'beta5' version
was flawed in many ways.

If the bug still exists we can always re-open it.

Note: See TracTickets for help on using tickets.