Opened 14 years ago

Closed 14 years ago

#1999 closed defect (wontfix)

DOTT/WINCE: stamp and contract on PDA

Reported by: SF/truhlik_fredy Owned by: SF/arisme
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Day of the Tentacle

Description

I'm using PDA version 0.71, when i try to use stamp on
the contract, it crashes, when is use it in 0.71 PC win32
version, it is working. And then i'm using some item in
inventory with another one and i must scroll in
intventory, the cursor disapears (it is only normal cursor,
but not cursor with selected item).

Ticket imported from: #1185147. Ticket imported from: bugs/1999.

Attachments (1)

scummvmCrash.rar (964 bytes) - added by SF/truhlik_fredy 14 years ago.
packed scumm crashes logs

Download all attachments as: .zip

Change History (11)

comment:1 Changed 14 years ago by SF/khalek

By "PDA version" I assume you mean some version of
WinCE/PocketPC running on something like XScale?

In any event if you could somehow get a log of the details
scummvm prints out
when it bails that would be useful...

Changed 14 years ago by SF/truhlik_fredy

Attachment: scummvmCrash.rar added

packed scumm crashes logs

comment:2 Changed 14 years ago by SF/truhlik_fredy

Yes. I have iPAQ 3950 (Xscale (first version)), Windows
Mobile 2003 (update ROM to 3.0). I send you more crashes,
every time the same, i tried with more characters to doo it,
then i tried to stamp the contract withou scrolling trough
inventory (send many items to another character soo the
curent character have few items). And the last one crashed
when i hust clicked (or tapped) on the stamp.

comment:3 Changed 14 years ago by SF/khalek

Assigning to arisme to see if he can reproduce the behaviour.

comment:4 Changed 14 years ago by SF/khalek

Owner: set to SF/arisme

comment:5 Changed 14 years ago by SF/arisme

Access violation ... that's a new one :) I'll have a look.

comment:6 Changed 14 years ago by fingolfin

Summary: stamp and contract on PDADOTT/WINCE: stamp and contract on PDA

comment:7 Changed 14 years ago by SF/generalleoff

This bug happens on the current Windows CVS builds as well.
The game just dumps out saying "Fatal signal: Segmentation
Fault (SDL Parachute Deployed)".

Unable to check this in latest stable build due to save
games being incompatable.

comment:8 Changed 14 years ago by SF/generalleoff

I have further info on this bug.

It only happens if you use the "use" verb. Press "Use"
select "stamp" use "stamp" on "Contract" and the game will
crash.

However Just selecting the stamp and then the contract will
work fine.

comment:9 Changed 14 years ago by SF/arisme

Resolution: wontfix
Status: newclosed

comment:10 Changed 14 years ago by SF/arisme

OK. Closing it then, since there's a well known workaround
and it seems to crash on the desktop version as well
according to your report :)

Note: See TracTickets for help on using tickets.