Opened 15 years ago

Closed 15 years ago

Last modified 10 years ago

#1844 closed defect (fixed)

SKY: Three compile warnings

Reported by: SF/madm00se Owned by:
Priority: normal Component: Engine: Sky
Keywords: build Cc:
Game: Beneath a Steel Sky

Description

ScummVM latest cvs as of 2004-12-15 21:10 CET
Platform: gcc version 3.2.3 (mingw special 20030504-1)
on WinXP

sky/control.cpp: In member function `uint32
Sky::Control::prepareSaveData(uint8*)':
sky/control.cpp:1172: warning: declaration of `cnt'
shadows a previous local
sky/control.cpp:1149: warning: shadowed declaration is here

sky/control.cpp: In member function `void
Sky::Control::importOldCompact(Sky::Compact*,
uint8**, short unsigned int,
short unsigned int, char*)':
sky/control.cpp:1207: warning: declaration of `type'
shadows a parameter
sky/control.cpp:1193: warning: shadowed declaration is here

sky/compact.cpp: In member function
`Sky::SkyCompact::SkyCompact()':
sky/compact.cpp:162: warning: unused variable `uint32
debcnt'

Ticket imported from: #1086035. Ticket imported from: bugs/1844.

Change History (5)

comment:1 by fingolfin, 15 years ago

Resolution: worksforme

comment:2 by fingolfin, 15 years ago

Hm, can't reproduce this with latest CVS and gcc 3.3 (and all warnings,
including -Wshadow and -Werror, enabled).
In fact the code doesn't match up with your error messages at all, I think
it was quite heavily changed recently...

comment:3 by SF/madm00se, 15 years ago

Seems lavosspawn fixed them. Closing.

comment:4 by SF/madm00se, 15 years ago

Status: newclosed

comment:5 by Kirben, 10 years ago

Keywords: build added
Resolution: worksformefixed
Note: See TracTickets for help on using tickets.