Opened 15 years ago

Closed 15 years ago

#1819 closed defect (fixed)

MIVGA: Sticky cutscene text

Reported by: SF/madm00se Owned by: eriktorbjorn
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 1

Description

If you skip the cutscene that appears when you first
exit the SCUMM bar while the word "Meanwhile..." is on
the screen, the text doesn't go away. It even sticks if
you change room. It does go away, though, in certain
cases when some other text appears on the screen - but
not any text. It doesn't reappear either if you save
and load.

Ticket imported from: #1060568. Ticket imported from: bugs/1819.

Attachments (2)

mi1-fix1.diff (1.1 KB ) - added by eriktorbjorn 15 years ago.
One possible fix against a November 8 snapshot
mi1-fix2.diff (1.0 KB ) - added by eriktorbjorn 15 years ago.
Another possible fix against a November 8 snapshot

Download all attachments as: .zip

Change History (12)

comment:1 by fingolfin, 15 years ago

To process your bug report appropriately, we need you to
provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for
us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:2 by SF/madm00se, 15 years ago

Component: Engine: SCUMM
Game: Monkey Island 1

comment:3 by SF/madm00se, 15 years ago

Bah, I forgot the important bits, sorry.

SCUMM Version: Latest CVS compiled with MinGW on Windows XP
Game: Floppy MonkeyVGA in English v. 5.0.19

I won't attach a save game as the bug occurs around 10
seconds into the game (less if you fast mode to it).

I've no idea when it appeared since I haven't updated my
scummvm in quite a while.

comment:4 by eriktorbjorn, 15 years ago

Happens in the CD version as well. Maybe abortCutscene() has
to clear any remaining text?

comment:5 by eriktorbjorn, 15 years ago

I think I see what's happening, though I don't know what's
the correct behaviour here.

The restoreCharsetBg() function is called, which should
clear the text, but since _vm->_currentRoom is zero, the
text surface isn't cleared. I guess either
restoreCharsetBg() should be changed to clear the text
surface, or the charset renderer should be changed not to
use the text surface in room zero.

by eriktorbjorn, 15 years ago

Attachment: mi1-fix1.diff added

One possible fix against a November 8 snapshot

by eriktorbjorn, 15 years ago

Attachment: mi1-fix2.diff added

Another possible fix against a November 8 snapshot

comment:6 by eriktorbjorn, 15 years ago

I've attached two possible patches. Both of them fix the
immediate problem, but as I said I don't know which one of
them - if any - is the most correct one.

Fingolfin, you're a lot more familiar with this code than I
am. Any comments?

comment:7 by eriktorbjorn, 15 years ago

Owner: set to fingolfin

comment:8 by fingolfin, 15 years ago

Both patches make sense and look fine to me. I can't really help much
with deciding which one to use, though... I guess either one could
potentially cause problems and/or fix additional issues :-).

One thing to try might be to check out more places where room 0 is used
(like in many game intros, I believe).

comment:9 by eriktorbjorn, 15 years ago

Owner: changed from fingolfin to eriktorbjorn
Resolution: fixed
Status: newclosed

comment:10 by eriktorbjorn, 15 years ago

In that case, I'll just pick one and we'll see what happens.
(I've picked the one that changes gfx.cpp.)

Note: See TracTickets for help on using tickets.