Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#1721 closed defect (fixed)

DIG: Cursor disappears/game unplayable after adjusting lens

Reported by: SF/tbcarey Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: script Cc:
Game: The Dig

Description

I remember this occuring haphazardly with any of the lenses, but I am able to reproduce the error faithfully in one specific location.

After fixing the broken panel on the map spire lightbridge control panel, Boston does not stop talking [mouth continues to move]. If you then attempt to use the control panel at least once [note: particularly without having adjusted the lens first] and it does not work, Boston will continue to move his mouth. Adjusting the lens after this causes the cursor to disappear entirely and renders the game essentially unplayable/frozen, although the background animation continues to play.

As noted above, this happens with any number of lenses throughout the game; if Boston adjusts them after having used the control panel once and failed, the game usually exhibits the above behavior, locking up.

I have attached a savegame at the point immediately before the lock-up would occur. Move the lens to lock the game up. If it does not occur the first time, move it several times and it should.

I'm using today's CVS build on Win32 with the English version of 'The Dig'.

Ticket imported from: #1009154. Ticket imported from: bugs/1721.

Attachments (1)

dig.s21 (22.9 KB ) - added by SF/tbcarey 16 years ago.
'The Dig' Pre-Lock Up Savegame

Download all attachments as: .zip

Change History (12)

by SF/tbcarey, 16 years ago

Attachment: dig.s21 added

'The Dig' Pre-Lock Up Savegame

comment:1 by SF/tbcarey, 16 years ago

Summary: Cursor disappears & game is unplayable after adjusting lensDIG: Cursor disappears/game unplayable after adjusting lens

comment:2 by eriktorbjorn, 16 years ago

I think it's roomobj-56-395 that's waiting for actor 3 to be drawn - case 226 in o6_wait(). Some kind of "wait for animation to finish", perhaps, but the 'needRedraw' flag is never cleared.

comment:3 by eriktorbjorn, 16 years ago

At least one reason needRedraw is set appears to be that akos_increaseAnims() keeps succeeding, even though Boston isn't moving in any way I can see. Not after I adjust the lens, at least.

If I do something that causes his mouth to stop moving before I adjust the lens, it doesn't hang for me.

Maybe the problem with the moving lips happens when an actor is talking without being on screen... but if so, it ought to happen when using the PenUltimate at the beginning of the game as well. Oh well, I don't have the time to look any more at this right now.

comment:4 by fingolfin, 16 years ago

Owner: set to Kirben

comment:5 by fingolfin, 16 years ago

Maybe the recent no_talk_anim / talkStartFrame changes are responsible for this? See also bug #954605 where Guybrush doesn't stop moving his mouth
<https://sourceforge.net/tracker/index.php? func=detail&aid=954605&group_id=37116&atid=418820> Assigning to Kirben to make him aware of this tracker item, maybe he has some good idea(s)

comment:6 by Kirben, 16 years ago

The problem was caused by one small change been lost in stopTalk() of scumm/actor.cpp during my changes. The a->isInCurrentRoom() check is only for scumm 1 - 6 games, scumm7/8 games shouldn't be checked.

comment:7 by Kirben, 16 years ago

Resolution: fixed
Status: newclosed

comment:8 by SF/ihcra, 16 years ago

im afrain im not so clever with this debugging lark - i just like playing the games...

i have the same type of freeze but at the tomb spire light bridge

i hear background music but the mouse pointer is invisibl and the game is unresponsive to anything but pause, save or quit commands

im using 0.7.0 ScummVM on macos x

is it possible to fix or do i have to start the gam over - its my only savegame

comment:9 by Kirben, 16 years ago

Are you using the daily snapshot for MacOS X ? the current snapshot doesn't include the fix and you will need to wait for the next snapshot.

comment:10 by SF/ihcra, 16 years ago

yes that daily snapshot - ill just wait fro the update then

how long is the lag between windows builds and macosx builds?

not a nag - just a query

comment:11 by Kirben, 16 years ago

The Mac OS X snapshot was just updated by porter, please try it now.

Note: See TracTickets for help on using tickets.