Opened 15 years ago

Closed 15 years ago

#1709 closed defect (fixed)

DIG: Scummvm freezes

Reported by: SF/zautni Owned by: eriktorbjorn
Priority: high Component: Engine: SCUMM
Keywords: Cc:
Game: The Dig

Description

The Dig (PC,english), Suse Linux 9.1 Kernel 2.6.5.-7.104
Scummvm 0.6.1b

After opening the third door (with the combination of
the orange engraved rod from the underwater cave) I
come by „tram“ to a steep coast scenario. When I try to
leave this scenario („up“) Scummvm freezes or crashes
down!!!

Regards
Andreas

Ticket imported from: #1006783. Ticket imported from: bugs/1709.

Attachments (2)

dig.s03 (19.6 KB ) - added by SF/zautni 15 years ago.
save game
0.6.1b-fix.diff (841 bytes ) - added by eriktorbjorn 15 years ago.
Patch against ScummVM 0.6.1b

Download all attachments as: .zip

Change History (15)

by SF/zautni, 15 years ago

Attachment: dig.s03 added

save game

comment:1 by fingolfin, 15 years ago

Priority: normalhigh
Summary: Scummvm freezesDIG: Scummvm freezes

comment:2 by eriktorbjorn, 15 years ago

Owner: set to aquadran

comment:3 by eriktorbjorn, 15 years ago

I can reproduce this with 0.6.1b but not with the CVS
version. This is the relevant part of the backtrace I get:

(gdb) bt
#0 0x77f9e124 in _libwinmm_a_iname ()
#1 0x003f0000 in ?? ()
#2 0x77f85010 in _libwinmm_a_iname ()
#3 0x77f58b37 in _libwinmm_a_iname ()
#4 0x77c2ab2e in _libwinmm_a_iname ()
#5 0x004c0974 in Scumm::BundleMgr::closeFile() (this=0x152cb80)
at scumm/imuse_digi/dimuse_bndmgr.cpp:162
#6 0x004c07a4 in Scumm::BundleMgr::~BundleMgr()
(this=0x152cb80)
at scumm/imuse_digi/dimuse_bndmgr.cpp:126
#7 0x004af56d in
Scumm::ImuseDigiSndMgr::closeSound(Scumm::ImuseDigiSndMgr::soundStruct*)
(this=0x1511928, soundHandle=0x1511978)
at scumm/imuse_digi/dimuse_sndmgr.cpp:400
#8 0x004af463 in Scumm::ImuseDigiSndMgr::openSound(int,
char const*, int, int, int) (this=0x1511928, soundId=10000,
soundName=0x22f2c0 "WAVES.012",
soundType=2, volGroupId=1, disk=-1)
at scumm/imuse_digi/dimuse_sndmgr.cpp:376
#9 0x00497f4f in Scumm::IMuseDigital::startSound(int, char
const*, int, int, AudioStream*, int, int, int)
(this=0x1511588, soundId=10000,
soundName=0x22f2c0 "WAVES.012", soundType=2,
volGroupId=1, input=0x0,
hookId=0, volume=127, priority=127)
at scumm/imuse_digi/dimuse_track.cpp:121
#10 0x00480270 in Scumm::IMuseDigital::startVoice(int, char
const*) (
this=0x1511588, soundId=10000, soundName=0x22f2c0
"WAVES.012")
at scumm/imuse_digi/dimuse_script.cpp:212
#11 0x00483541 in Scumm::ScummEngine::playSpeech(unsigned
char const*) (
this=0x14bede8, ptr=0x14ce360 "WAVES.012") at
scumm/string.cpp:856
#12 0x00474d1c in Scumm::ScummEngine::actorTalk(unsigned
char const*) (
this=0x14bede8, msg=0x2011854 "/WAVES.012/Rumble! Rumble!")
at scumm/actor.cpp:1165

So something about Digital iMUSE... strange, because that
part of the code is, as far as I can see, pretty similar
between 0.6.1b and the CVS version.

comment:4 by eriktorbjorn, 15 years ago

I've attached a patch that seems to fix it, but I'm not
entirely sure. The crash isn't 100% reproducable for me, so
it's hard to say for certain if it's gone.

The patch does fix the Valgrind warnings I got when running
it under Linux though.

by eriktorbjorn, 15 years ago

Attachment: 0.6.1b-fix.diff added

Patch against ScummVM 0.6.1b

comment:5 by fingolfin, 15 years ago

Well, if the patch fixes valgrind warnings, why not just apply it right now
anyway? No need to hold it back, is there?

comment:6 by eriktorbjorn, 15 years ago

Ok, I've applied the patch to branch-0-6-0, and added a
section to the NEWS file for a possible 0.6.2 (or whatever
it'd be) release.

Aquadran, do you think these changes are enough to fix the
reported bug?

comment:7 by aquadran, 15 years ago

i'm currently is off from scummvm, anyway it's possible
enough. There is hack for stopping sounds in imuse depend
for that param. it should be always disabled in the dig.

comment:8 by fingolfin, 15 years ago

Andreas Zautner, can you still reproduce the problem with a current daily
build (available from our web page; or just build from the CVS sources
directly, if you know how to do that) ?

Thanks!

comment:9 by fingolfin, 15 years ago

Status: newpending

comment:10 by SF/zautni, 15 years ago

Hi fingolfin

With the current daily build of Scummvm I am getting quiet
good through the next picture (after the bug), but in the
next location after adjusting the lens there is the next
bug- the mouse coursor disappears.
(It still works while aktivating the menu.)

Thanks
Andreas

comment:11 by SF/zautni, 15 years ago

Status: pendingnew

comment:12 by fingolfin, 15 years ago

Owner: changed from aquadran to eriktorbjorn
Resolution: fixed
Status: newclosed

comment:13 by fingolfin, 15 years ago

Thanks zautni. That would be another bug, though, please file a seperate
report for it. Thanks!

Note: See TracTickets for help on using tickets.