Opened 16 years ago

Closed 15 years ago

Last modified 13 years ago

#1595 closed defect (fixed)

Simon1(DOS) crashes on PocketPC on specific game screen.

Reported by: SF/jocula Owned by: SF/arisme
Priority: normal Component: Engine: AGOS
Keywords: Cc:
Game: Simon the Sorcerer 1

Description

ScummVM version:
PockePC (ARM) port of ScummVM 0.6.0 (build Mar 15
2004 00:03:06 ("stable")).
(as well reproduced on later ARM build Mar 30 2004
00:22:19)).
Bug *is not reproduced* on Win32 port of ScummVM
(works just fine).
------------
Bug details, including instructions on reproducing:
Area: Dwarf's mine->Rightmost room (with Beer barrels
and drunk dwarfs).
After entering this game screen (by any way) after 1-3
seconds game crashes. Even if just stay and do not
tap/press buttons.
To reproduce: load attached savefile and walk to the
right-bottom path. On the appeared screen wait several
seconds. 100% crash.
-----------
Language of game: English
-----------
Version of game: DOS (floppy)
-----------
Platform and Compiler:
PocketPC iPAQ 1940 ("bios" version 1.10), Windows
Mobile 2003, ARM.
(also reproduced on iPAQ 2210(Mobile2003/ARM),
Cassiopea 125(WindowsCE/MIPS))
Dunno compiler (binary downloaded).
-----------
Attach a save game if possible: attached
-----------
Cannot download 0.5.x binary to check, sorry.

Ticket imported from: #934343. Ticket imported from: bugs/1595.

Attachments (1)

simon1.zip (811 bytes ) - added by SF/jocula 16 years ago.
Savegame to reproduce the bug.

Download all attachments as: .zip

Change History (17)

by SF/jocula, 16 years ago

Attachment: simon1.zip added

Savegame to reproduce the bug.

comment:1 by SF/arisme, 16 years ago

I'll check it this week-end, if possible

comment:2 by Kirben, 15 years ago

What is the status of this item?

comment:3 by SF/arisme, 15 years ago

Seems fine in 0.6.1b. Please recheck with your version when
it'll be released to close the bug.

comment:4 by SF/schnibble, 15 years ago

I've got the same problem, both in ScummVM 0.6.0 and
ScummVm 0.6.1b (aug 5 2004 21:17:44).

ScummVM version (scummvm 0.6.0 and ScummVm 0.6.1b
(aug 5 2004 21:17:44))

Bug details, including instructions on reproducing
Start a new game, open the drawer and pickup the scissors.
Walk to the bar and use the scissors on the dwarf on the left.
Walk to the screen with the dwarfmine, pick up the stone in
front of the dwarfmine and look at it. Wear the dwarfbeard
and enter the mine. Password is Beer (option 7). In the mine,
walk to the right side. You arrive in a room with two dwarfs
and some barrels and here the game will crash to the
Todayscreen. (This is the shortest way to the crash, I
believe).

When the game has crashed to the Todayscreen of my Ipaq
1930 PocketPC my taskbar is gone (I see instead of the
taskbar the background of the game).

Language of game (English, German, ...)
English

Version of game (Talkie, Floppy, ...)
Floppy, DOS

Platform and Compiler (Win32, Linux, ...)
PocketPC on Ipaq 1930 PDA

Attach a save game if possible
Can't upload today, maybe tomorrow.

If this bug only occured recently, please note the last version
without the bug, and the first version including the bug. That
way we can fix it quicker by looking at the changes made.
Both ScummVm 0.6.0 and 0.6.1b have this problem on the
Ipaq.

This crash doesn't occur on my laptop with WinXP (tested it).

Arjen

comment:5 by SF/arisme, 15 years ago

I don't really understand what's going on, because the saved
game is working fine for me. I'll retest from the beginning
of the game later, in the meantime could you try with the
latest CVS head snapshot available from
http://arisme.free.fr/PocketScumm, and post the details of
the exception if a crash occurred ?

Thanks

(note that it's normal to have a missing taskbar if a crash
occurs, because ScummVM won't be able to refresh it -
running ScummVM again and exiting cleanly should fix this).

comment:6 by SF/schnibble, 15 years ago

I'll install the CSV you've mentioned and try it. But where can
I find the details of the exception?

By the way, I can't restart ScummVM without resetting after
a crash, because I need the taskbar (Start) to start
ScummVM.

I really want to thank you (and the rest) for the development
of ScummVM. I really like playing those old adventures again
on mij PDA!!!!

Arjen

comment:7 by SF/arisme, 15 years ago

Details of the exception will be stored in a .txt file in
the root directory of the device with a name looking like
scummvm_exception_date.txt

And you should run ScummVM from the File Explorer (not from
the Start Menu) when running a game that crashes :) (OK,
you'll only know after it crashes once :p)

comment:8 by SF/schnibble, 15 years ago

There are only two files in my root:

scummvm_stderr (is empty)
and
scummvm_stdout, containing:

Looking for simon1dos
Trying to start game 'Simon the Sorcerer 1 (DOS)'

And running from the File Explorer indeed helps, thank you.

Arjen

comment:9 by SF/schnibble, 15 years ago

I've installed the latest CSV en when the game crashes, this
is what the file 'scummvmCrash_11_08_2004_10_25_46.txt'
says:

----------------------------------------
Exception Datatype Misalignment Flags 00000000 Address
00147fc0
----------------------------------------
Context dump
R0=004fe251 R1=00000a00 R2=00000fa0 R3=004fe249
R4=00000065
R5=0000000c R6=00440020 R7=00440685 R8=00000004
R9=00000060
R10=00440020 R11=00000060 R12=1a37f9ac
Sp=1a37f980 Lr=00000a00 Pc=00147fc0 Psr=6000001f
----------------------------------------
Memory dump at 00147f8e
51 e3 03 00 8a e0 0c 00
80 22 04 30 90 e5 64 10
41 22 01 00 51 e3 81 01
83 e0 bc 12 dd e1 fa 2e
a0 e3 ff e0 01 e2 01 18
a0 e1 0e e4 a0 e1 21 1c
8e e0 b4 10 c0 e1 09 18
a0 e1 21 18 a0 e1 ff e0
01 e2 01 18 a0 e1 0e e4
a0 e1 21 1c 8e e0 01 e0
d0 e5 b6 10 c0 e1 7d 2d
a0 03 00 10 d0 e5 03 b0
a0 e1 01 14

Arjen

comment:10 by SF/arisme, 15 years ago

Thanks, I'll trace it back tonight and try to fix it (it's a
misalignment so it should be easy to spot ... but I still
don't understand why it works fine on my device)

comment:11 by SF/arisme, 15 years ago

Please retry with tonight version :)

comment:12 by SF/schnibble, 15 years ago

Perfect, you've solved the problem!

Thanks,

Arjen

comment:13 by SF/arisme, 15 years ago

Fixed in CVS, but I can't close it myself :)

comment:14 by Kirben, 15 years ago

Owner: set to SF/arisme
Resolution: fixed
Status: newclosed

comment:15 by fingolfin, 14 years ago

Component: Engine: AGOSEngine: AGI
Game: Simon the Sorcerer 1Space Quest 1

comment:16 by Kirben, 13 years ago

Component: Engine: AGIEngine: AGOS
Game: Space Quest 1Simon the Sorcerer 1
Note: See TracTickets for help on using tickets.