Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#1550 closed defect (worksforme)

COMI: CD changing not working properly

Reported by: SF/mephisto275 Owned by: fingolfin
Priority: low Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

When i Start the 3-rd Chapter in MI3 (on the Ship)
i have to put in the second CD, but after 2 seconds the
GUI asksme to put in the 1-st CD , then once again the
2-nd and so on, so i cannot play the game because i've
got to change the cd from 1-st to 2-nd every 2 seconds.

In Simple words: the GUI can't find the data from CD 1,
required by the "Setup" , and in the same moment the
Game can't find the Data from the CD 2 reqired to play.

Is there a hint, or is it possilble to show the Scumm VM
where the Second CD is in ??

I've also Installed the game by the setup from the prog.
but scumm can't find the game in this Folder

I have Daemon tools on my PC, but i've tried ist also with
the "normal" cd-player.

if you have a solution to this problem, please mail me to :
sirhc@t-online.de

Ticket imported from: #920462. Ticket imported from: bugs/1550.

Change History (12)

comment:1 by SF/mephisto275, 16 years ago

Priority: normalhigh

comment:2 by SF/mephisto275, 16 years ago

Priority: highblocker

comment:3 by SF/mephisto275, 16 years ago

Priority: blockerlow

comment:4 by eriktorbjorn, 16 years ago

ScummVM doesn't deal handle playing multi-CD games from the
CDs very well at this time. The README file has a section
about playing them from hard disk, though.

comment:5 by fingolfin, 16 years ago

I can't reproduce this using boot param 460 (which puts me right before
the end of act II). So please attach a relevant savegame, we can only fix
bugs we can reproduce. Thanks!

comment:6 by SF/mephisto275, 16 years ago

I've read the Readme to the Scumm VM - so the problem is
solved. :-)

Sorry for this mistake - MI3 works already - i should read first,
and then ask for help

comment:7 by SF/mephisto275, 16 years ago

To process your bug report appropriately, we need you to
provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for
us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:8 by fingolfin, 16 years ago

Summary: CD changingCOMI: CD changing not working properly

comment:9 by fingolfin, 16 years ago

The problem is solved -- how?

Do you mean you copied the COMI files to your HD (which is a
workaround, not a fix of the issue :-), or did the problem go away?

If you just worked around the problem by copying the files to your HD,
I'd still be grateful if you could attach a savegame with which one can
reproduce the problem, so that I can fix the issue :-)

comment:10 by fingolfin, 16 years ago

Status: newpending

comment:11 by SF/mephisto275, 16 years ago

The problem went away - i've read the Readme attached to
the scummvm.zip file , inside i've found the following passage:

"For this game, you'll need the comi.la0, comi.la1 and comi.la2
files. The
comi.la0 file can be found on either CD, but since they are
identical it
doesn't matter which one of them you use.

In addition, you'll need a resource subdirectory with all of the
files from the
resource subdirectories on both CDs. Some of the files appear
on both CDs, but
again they're identical."

So, if you only get the scummvm-path for the game to your
cd-rom, the scummvm does not support multiple cd drives - so
the error occurs after going to chapter 3 - try it - there is no
save game, it was only the "installation" problem, after doing
the way the readme describes, the "corrupt" savegame works
perfect.

thx anyway - Mephisto

comment:12 by SF/mephisto275, 16 years ago

Owner: set to fingolfin
Resolution: worksforme
Status: pendingclosed
Note: See TracTickets for help on using tickets.