Opened 16 years ago

Closed 16 years ago

#1509 closed defect (worksforme)

COMI: Crash on start of Act 4

Reported by: SF/offsky Owned by: SF/ender
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

I'm using the 2/23/04 build of 0.6.0pre on Mac OS X. I
am playing MegaMonkey fullscreen with aspect ratio
correction and subtitles turned on.

I was able to defeat Captain Rottingham at the insult
duel (Although act 3 was very difficult due to the
subtitles going crazy fast and there being no voice.
There were many visible glitches in the cannon battles
as well, but I'm sure you know about that already).

After I beat Captain Rottingham, I get the splash
screen for Part 4 and it plays a little music and then
right as the game is about to go into act 4 I get this
crash

Error (7:327:0x24): Chunk type is different from
expected : 4360ca8f!= 41484452

I have attached the save game right before the crash point.

Ticket imported from: #907180. Ticket imported from: bugs/1509.

Attachments (1)

comi.s11 (57.8 KB ) - added by SF/offsky 16 years ago.
Saved right before crash at act 4 start

Download all attachments as: .zip

Change History (18)

by SF/offsky, 16 years ago

Attachment: comi.s11 added

Saved right before crash at act 4 start

comment:1 by fingolfin, 16 years ago

The crash/error occurs in the SMUSH playback code (it expects a chunk
of type 'AHDR' but finds garbage).

comment:2 by fingolfin, 16 years ago

Owner: set to aquadran

comment:3 by fingolfin, 16 years ago

Summary: COMI (Mac): Crash on start of Act 4COMI: Crash on start of Act 4

comment:4 by aquadran, 16 years ago

it works fine for me

comment:5 by aquadran, 16 years ago

Resolution: worksforme

comment:6 by SF/offsky, 16 years ago

Is there any other information that I can provide to help you isolate this
bug? I am running OS 10.3.2 on a Dual 500MHz G4. Since the bug
report I have tried running it not full screen, but I get the same error. If
you could post a save game from 10 seconds after my save game, Ill see
if I can run it from that point forward.

comment:7 by fingolfin, 16 years ago

aquadran, did you use the attached savegame for testing?

We already found out some time ago that often, things work fine when
using bootparams, but do not work correctly when playing normally up to
the trouble spot.

comment:8 by aquadran, 16 years ago

yes, i used savegame. maybe it's endian specific bug

comment:9 by aquadran, 16 years ago

AHDR is header of animation, it's really strange

comment:10 by aquadran, 16 years ago

what is your md5sum for file "wreck.san" ?

comment:11 by SF/offsky, 16 years ago

Are there any debugger commands I can run to help diagnose
the problem? I have confirmed that it still exists in the
March 5 build.

comment:12 by fingolfin, 16 years ago

You should read & follow the comments on this bug report, for starters
:-) The current best theory is that your data files are corrupt, considering
that aqudran can't reproduce the problem. To exclude that possibility, we
need the MD5 checksum of your data files (or in this case, of wreck.san
specifically, although it wouldn't hurt to mention the others, too).

To get the md5 sum, you can use the "md5" tool in Terminal.app.

comment:13 by SF/offsky, 16 years ago

Sorry, I didnt realize the information request was directed
to me. Here is the Md5 information that I got from runing
the terminal command in the RESOURCE directory:

% md5 *
MD5 (BBSAN.SAN) = ff9f5d3d05e72bada4ba1f8849352cf7
MD5 (CURSERNG.SAN) = 6cceb9586037e325f429836efbfd12c5
MD5 (FG010GP.SAN) = e4fcdbd3487886a06d56492696fd1c84
MD5 (FINALE.SAN) = 953a1221941e53c5b7ae0c4f99395064
MD5 (FONT0.NUT) = 8b9f2180203fad6fbe22db9a48b6a839
MD5 (FONT1.NUT) = c5c8e3a0ab861b38f9805fbc16f62550
MD5 (FONT2.NUT) = c5c8e3a0ab861b38f9805fbc16f62550
MD5 (FONT3.NUT) = 90d178dacab8dd14c40e61005131d118
MD5 (FONT4.NUT) = 97a7d3fb528f16e86cf3970ace75e66c
MD5 (KIS030.SAN) = 71725a54a64252628c6b021341520632
MD5 (LANGUAGE.TAB) = 2daf3db71d23d99d19fc9a544fcf6431
MD5 (LAVARIDE.SAN) = 7d0ad52e7fe32d819edf8c6095adbedf
MD5 (LIFTCRSE.SAN) = ec2d9d57148e21f46896a359b239fcf4
MD5 (MORESLAW.SAN) = 214d0a3b9c8fffc77cc35be8a0101d03
MD5 (MUSDISK1.BUN) = 9e662f111ae0cdf9f68c594475a891a2
MD5 (MUSDISK2.BUN) = 3ed44debfb6ce1de6a2cd99f4ed0c408
MD5 (NEWBOOTS.SAN) = dd7b5beaa17e4eebb896ddbca9ffb2f0
MD5 (OPENING.SAN) = 833ba64fde983bcd62f7b5e769e60130
MD5 (SB010.SAN) = b965b2753c541391e90396ab20f3bc96
MD5 (SB020.SAN) = b6167e556992b16fe68c628e40cb2f04
MD5 (SINKSHP.SAN) = 876086bf27ad1c9f1053992595bce7e9
MD5 (VOXDISK1.BUN) = c25c4a1a0ebdcfa50f4027541b096326
MD5 (VOXDISK2.BUN) = 42da0f1e43c8ad6b88473fc478f65292
MD5 (WRECKSAN.SAN) = 89659ad147fb09dc0594e72074688fa4
MD5 (ZAP010.SAN) = 8bbe87c4380333f4c8513d00443f4911

My source files were copied directly off of a Mac copy of
the game.

comment:14 by aquadran, 16 years ago

WRECKSAN.SAN, VOXDISK2.BUN and maybe more have wrong md5sum.
there is one version of comi - pc and that mean your files
are corrupted. what do you mean "Mac copy of the game" ?

comment:15 by fingolfin, 16 years ago

Just FYI; my MD5s match aquadrans, so I also think that those two files
aquadran mentioned must be damaged for you, Jake

comment:16 by SF/ender, 16 years ago

Owner: changed from aquadran to SF/ender
Status: newclosed

comment:17 by SF/ender, 16 years ago

It seems your copy is corrupt. You may wish to try and return your game
to LucasArts and ask for a replacement CD.

Good luck with that, however :)

Closing bug.

Note: See TracTickets for help on using tickets.