Opened 15 years ago

Closed 15 years ago

Last modified 10 years ago

#1477 closed defect (invalid)

FT: Crash in junk yard

Reported by: SF/colin_taylor Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Full Throttle

Description

From the first junk yard location, moving to the right
causes a crash with the following message:

Error: (28:2013:0x9526): readArray: invalid array 422 (0)

I have tried this with most of the recent daily builds
(Windows 98 only).

ScummVM 0.6.0pre (Feb 20 2004 15:37:45)
English
Talkie

Ticket imported from: #901508. Ticket imported from: bugs/1477.

Attachments (1)

ft.s06 (8.0 KB) - added by SF/colin_taylor 15 years ago.
FT save game

Download all attachments as: .zip

Change History (7)

Changed 15 years ago by SF/colin_taylor

Attachment: ft.s06 added

FT save game

comment:1 Changed 15 years ago by SF/colin_taylor

Summary: Crash in junk yardFT: Crash in junk yard

comment:2 Changed 15 years ago by sev-

I get the bug triggered with your save but when I start the
game from the beginning up to this point I can't reproduce
it anymore. Do you remember what did you exactly do before
this? Because it seems that it doesn't happen with routine
gameplay I'm used to.

Also it may happen that the savefile is just broken, nothing
more.

comment:3 Changed 15 years ago by fingolfin

sev, did you try to make savegames of your own before getting there,
i.e. play from the start, make a save in the same spot as Colin, then quit
ScummVM, load the save, and go on?
That way you can ensure that it's not just a simple problem with
readArray not storing data properly...

comment:4 Changed 15 years ago by SF/colin_taylor

Hi,

Thanks for the suggestions. I have tried all of my saved
games going back to the oldest one (right at the begining
when you've just got you bike keys back). Playing through to
the junk yard causes the same crash.

However... Starting a new game the problem does NOT
occur. I have tried this with several save points, including
exiting summvm completely, going back in and reloading the
save game... No problem.

I guess sev was right. I must have corrupted my save file at
a very early point in the game. Maybe a side effect of one of
the previous CVS builds.

Anyway, thanks again and I think we can close this bug now.

Colin

comment:5 Changed 15 years ago by SF/colin_taylor

Status: newclosed

comment:6 Changed 10 years ago by Kirben

Owner: set to Kirben
Resolution: invalid
Note: See TracTickets for help on using tickets.