Opened 6 months ago

Closed 6 months ago

Last modified 6 months ago

#14763 closed defect (invalid)

Mugger Bug in SQ1 VGA

Reported by: ArthurWalden Owned by: sluicebox
Priority: normal Component: Engine: SCI
Version: Keywords: SQ1 SCI, mugger
Cc: ArthurWalden Game: Space Quest 1

Description

I am running ScummVM version 2.7.1.

(Admittedly, I can't be completely sure this is a bug, but I believe it to be.)

In the SCI version of Space Quest 1, I cannot get the mugger in Ulence Flats to appear. To parallel what I did to get him to appear in the AGI version, when arriving in Ulence Flats, I sold my skimmer, then I went to Tiny's Used Spaceships and got his spiel for all three ships he will sell you (I even clicked the eye cursor on all of them), then I went into the bar and played the slot machine until I had over 300 buckazoids (and the machine exploded). However, when I exited the bar, there was no mugger there. He definitely appears after performing the (closest) equivalent actions in the AGI version. (It's possible I just don't know what actions are required to trigger the mugger in the SCI version, but this seems like a bug to me.)

I am playing the English Steam version of the game. I believe this to be a port of Sierra's floppy version but am not completely sure.

I am running the game on Windows 11 Home, version 22H2. I believe it is x64.

Attachments (1)

sq1sci.009 (35.7 KB ) - added by ArthurWalden 6 months ago.

Download all attachments as: .zip

Change History (3)

by ArthurWalden, 6 months ago

Attachment: sq1sci.009 added

comment:1 by sluicebox, 6 months ago

Owner: set to sluicebox
Resolution: invalid
Status: newclosed

Hello and welcome! I just saw this ticket after patching your PQ3 wrong-ending bug: https://github.com/scummvm/scummvm/commit/a26252fadf2535185680d5a12d6fa542a98c658b

If I had seen this earlier, I would have thanked your github handle in the commit message. Sorry! We'll get 'em next time. I guess you'll just have to report more game-breakers =)

The trigger for the mugger is: exit the bar with at least 130 buckazoids before breaking the slot machine. Once you get over 300 and break the machine, you're mugger-free. This trigger stayed the same in all SCI versions.

Thanks for providing the save file, that's always a huge help. I'm always happy to suss out if something like this is a weird trigger or not, it's usually a quick lookup in the decompiled scripts. It's a bit more work if I don't know the game well, like PQ3, but either way once we get a reproachable situation under the microscope we can see what's going on. You can also ping us on our discord server, that place is hopping, while the forums are pretty quiet these days. (I've never even had a forum account!)

Closing as original game behavior.

Version 0, edited 6 months ago by sluicebox (next)

comment:2 by ArthurWalden, 6 months ago

Thank you for telling me what to do. I'm glad it's not a bug.

Note: See TracTickets for help on using tickets.