Opened 16 years ago

Closed 16 years ago

#1432 closed defect (invalid)

SAMNMAX: VOC file header error

Reported by: SF/khalek Owned by: SF/khalek
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Sam and Max

Description

When running samnmax with latest CVS I get the
following error early in the intro:

WARNING: loadVOCfile: invalid header!
rate effect can only handle rates < 65536

I can't exit scummvm nornally and have to kill -9 the
process.

Running on Linux/PowerPC with latest bits of debian sid.

Ticket imported from: #889442. Ticket imported from: bugs/1432.

Change History (8)

comment:1 by fingolfin, 16 years ago

The rate error is simply a consequence of loadVOCFile() failing to
load something.

Where exactrly in the intro does it crash? And which precise
version of Sam&Max is this?

comment:2 by fingolfin, 16 years ago

Summary: SAMNMAX: rate error in introSAMNMAX: VOC file header error

comment:3 by fingolfin, 16 years ago

There is a patch in CVS now which will properly detect when
loading a VOC fails, and then will *not* pass it on to the mixer.

However, that is only a cure for the symptoms; the real question
should be, why exactly is it failing to load a VOC for you? Hum...

(you are not by chance using the FLAC patch?)

comment:4 by fingolfin, 16 years ago

BTW I can't reproduce this with latest CVS (even though I applied a
patch, there should still be a warning message). Using plain
english talkie Sam&Max.

Maybe you are using a special version, or have the FLAC patch
installed, or have a damaged/missing monster.sou file?

comment:5 by SF/khalek, 16 years ago

I'm using plain english talkie version of samnmax, without
any third party patches or private modifications.

I will verify my data files tomorrow.

I can't reproduce it on my main (x86 linux) pc either

comment:6 by fingolfin, 16 years ago

Note that I am (as you know, of course :-) on OSX/PowerPC. So an
endian issue is out of the game. Very strange.

comment:7 by SF/khalek, 16 years ago

Owner: set to SF/khalek
Resolution: invalid
Status: newclosed

comment:8 by SF/khalek, 16 years ago

md5sum /mnt/macos/Users/khalek/Games/samnmax/monster.sou
error processing
/mnt/macos/Users/khalek/Games/samnmax/monster.sou: failed in
buffer_read(fd): mdfile: Input/output error

ie this is a problem outside of ScummVM, closing

Note: See TracTickets for help on using tickets.