Opened 15 years ago

Closed 14 years ago

Last modified 14 years ago

#1430 closed defect (fixed)

SAM: Savage Jungle Inn music glitch

Reported by: eriktorbjorn Owned by: eriktorbjorn
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Sam and Max

Description

Sam & Max, english talkie
Recent CVS snapshot

When leaving the bigfoot party, the Savage Jungle Inn
music plays with the wrong instruments. Perhaps it's
using the instruments from the previous music?

Ticket imported from: #888248. Ticket imported from: bugs/1430.

Attachments (1)

samnmax.s30 (24.3 KB) - added by eriktorbjorn 15 years ago.
Savegame at the bigfoot party

Download all attachments as: .zip

Change History (8)

Changed 15 years ago by eriktorbjorn

Attachment: samnmax.s30 added

Savegame at the bigfoot party

comment:1 Changed 15 years ago by eriktorbjorn

The party music in that savegame sounds a bit strange, but
I'm pretty sure that's intentional. The band is just getting
warmed up to play another tune. If you wait a little while,
it will sound normal again.

You'll also notice that the Savage Jungle Inn sounds
different if you leave the party during this warmup,
compared to how it sounds if you leave once they've started
playing in earnest. This would seem to support the theory
that it's re-using the old instruments, but that's still
just a guess.

comment:2 Changed 15 years ago by SF/jamieson630

Owner: set to SF/jamieson630

comment:3 Changed 15 years ago by SF/jamieson630

I'm assigning this to my todo list so the next time Torbjrn
asks me about it in IRC, I won't have to go hunting for it. ;)

comment:4 Changed 14 years ago by eriktorbjorn

This could be related to bug #1202071. At least, it appears
to use the same music jump instruction as the Frog Rock
scene does.

comment:5 Changed 14 years ago by eriktorbjorn

It's room-52-212 that invokes the jump instruction like this:

soundKludge([257,69,0,2,3,4,300,0])

Unfortunately I have no idea to where in the track it's
supposed to be jumping.

comment:6 Changed 14 years ago by eriktorbjorn

I believe this bug was fixed along with #1202071. At least
it sounds good to me now.

comment:7 Changed 14 years ago by eriktorbjorn

Owner: changed from SF/jamieson630 to eriktorbjorn
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.