Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#1428 closed defect (worksforme)

BS1: Puzzle not working correct.

Reported by: SF/florob Owned by: SF/ender
Priority: normal Component: Engine: Sword1
Keywords: Cc:
Game: Broken Sword 1

Description

under the place with the jungler you have to open the
right door.
You can do this by using the tool to get there 2 times
with it.
It's not the way you should open the door even if i don't
know if that worked in the original game.
(sorry for my pour english)
latest daily build WinXP

Ticket imported from: #887756. Ticket imported from: bugs/1428.

Attachments (1)

SAVEGAME.012 (838 bytes) - added by SF/florob 15 years ago.
Savegame at the Arcs

Download all attachments as: .zip

Change History (10)

comment:1 Changed 15 years ago by eriktorbjorn

You mean using the tool on the right arch once to break it,
and then use it on the same arch once more? When I try that,
George just shrugs his shoulders, both with ScummVM and with
the original interpreter.

(This is with the Sold-Out Software PC version of the game.)

comment:2 Changed 15 years ago by SF/florob

The second time you have to use it on the little space
between wall and arch. Then for me the door closes
completely than you see george making the hole in it and it
disappears. Sold Out version, too.

comment:3 Changed 15 years ago by eriktorbjorn

Owner: set to lavosspawn

comment:4 Changed 15 years ago by eriktorbjorn

I still can't reproduce it, I'm afraid. Assigning to
Lavosspawn, since he did most of the work (all of the really
important work, actually) in getting the Broken Sword I
engine working with ScummVM. Perhaps he has some idea.

Changed 15 years ago by SF/florob

Attachment: SAVEGAME.012 added

Savegame at the Arcs

comment:5 Changed 15 years ago by SF/florob

So I uploaded a Savegame right there.
Here is how to produce the Bug:
1. Use the tool to open a gully (is there something short for
this? I'll call it tool from now) to make a hole in the right arc.
2. Use the things behind the hole twice to try to open the
door.
3. Use the tool on the gap. The cursor looks like when you
used the tool the first time there.
4. The door will close, you will make the hole a second time,
the door will disappear.

comment:6 Changed 15 years ago by eriktorbjorn

That makes it a lot clearer, which is good. Unfortunately I
still haven't managed to reproduce it here.

comment:7 Changed 15 years ago by SF/ender

Owner: changed from lavosspawn to SF/ender
Resolution: worksforme
Status: newclosed

comment:8 Changed 15 years ago by SF/ender

I can't reproduce it either. I'm going to close it as
unreproducable. It sounds you've ran into a fluke :)

comment:9 Changed 15 years ago by eriktorbjorn

I forgot to mention that I spoke to lavosspawn about it, and
he was able to reproduce it. If I understood him correctly
it's a bug in the script, in which case it probably happens
in the original interpreter as well.

Maybe it was fixed in some versions of the game and not in
others?

Note: See TracTickets for help on using tickets.