Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#1426 closed defect (fixed)

FT: Sound/Music/speech (almost) mute (0.6.0 critical)

Reported by: fingolfin Owned by: fingolfin
Priority: high Component: Engine: SCUMM
Keywords: Cc:
Game: Full Throttle

Description

With current CVS (and already *before* my pan->balance
modification just now), Full Throttle's sound output is almost
mute - I have to turn up the volume of my speakers almost
to the max to hear anything.

Not sure when exactly this regression was introduced, but I
think it must be quite recently.

This is release critical for 0.6.0

Ticket imported from: #887167. Ticket imported from: bugs/1426.

Change History (11)

comment:1 by aquadran, 16 years ago

it's fine for me

comment:2 by fingolfin, 16 years ago

In game it works fine, yes. But all the movies (e.g. the intro
movie, which is the first thing you see when you start FT in
scummvm) has the problem (and also all other movies).
No problems with The Dig, though. Maybe this is a problem with
insane and/or any changes made by sev...

comment:3 by fingolfin, 16 years ago

Owner: changed from aquadran to sev-

comment:4 by aquadran, 16 years ago

intro also works fine for me

comment:5 by aquadran, 16 years ago

intro also works fine for me

comment:6 by eriktorbjorn, 16 years ago

Volume-wise, the intro works fine for me as well. Some
endian problem, perhaps, though the volume itself is a byte
from what I understand, in which case the volume problem
might be secondary to something more sinister.

On the other hand, the FT intro crashes for me after a while
in handleFrameObject(). I'll file a separate bug report for
that...

comment:7 by fingolfin, 16 years ago

Just FYI, olki was able to reproduce the problem on his OS X
machine, too, but not on his x86/linux machine.

There are more portability bugs than just endian bugs, of course.
For example, the V6 code for some time had problems because it
did:
foo(pop(), pop());
The order of the two pop() statements is not defined in the C(++)
standard. As a result, we got differing behaviour depending on the
compiler and the target platform.
There are of course many more examples :-). I guess the
"easiest" way to track this bug down will be to do a "CVS
regression search" (I am still wondering about whether it'd pay off
to implement a nice helper tool for this, one which makes doing a
'binary search' in CVS easier ...)

comment:8 by fingolfin, 16 years ago

Before I forgot, olki also reported that he got
"AppendableMemoryStream overflow" messages in the FT intro.
See also bug #881535.

And I did some testing, inserted lots of printf statements, which
showed that playFtMusic is called once at the start of the FTInto,
like this:
playFtMusic("", 2, 127, 0, 0)
And startSound (of IMuseDigital, that is) *never* gets called.

comment:9 by fingolfin, 16 years ago

Owner: changed from sev- to aquadran

comment:10 by fingolfin, 16 years ago

Fixed in CVS. It was an endian bug, introduced by the change
found here:
<https://sourceforge.net/mailarchive/forum.php?
thread_id=3720406&forum_id=33067>

comment:11 by fingolfin, 16 years ago

Owner: changed from aquadran to fingolfin
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.