Opened 15 years ago

Closed 15 years ago

#1406 closed defect (fixed)

COMI: rates < 65536 regression

Reported by: SF/logicdeluxe Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

ScummVM 0.5.7cvs (Jan 22 2004 11:10:40)
Windows version. I tried UK CD right from the harddisk
and the German CD directly from CD. Both produce the
same error.
Right before the first interactive scene, Wally says:
"Quit your mumbling, captive!" and then the error appears:
(9:130:0x6A4): rate effect can only handle rates < 65536
Then ScummVM hangs and can not be quit. I have to kill it.
Escaping that scene, Wally is firing the cannon and
talks fine between the shots, but as soon as you try
talkling to him, the same thing happens with the
following error:
(9:2004:0x96B): rate effect can only handle rates < 65536
Without the talkie files, the crash doesn't happen.

Ticket imported from: #882081. Ticket imported from: bugs/1406.

Change History (3)

comment:1 Changed 15 years ago by fingolfin

Owner: set to fingolfin
Resolution: fixed
Summary: COMI: rates < 65536 regressionCOMI: rates &lt; 65536 regression

comment:2 Changed 15 years ago by fingolfin

We already have a fix, but can't commit it right now since CVS is
down.

comment:3 Changed 15 years ago by fingolfin

Status: newclosed
Note: See TracTickets for help on using tickets.