#14002 closed defect (fixed)

SAGA: IHNM: Can't load Windows scream.res on macOS anymore

Reported by: dwatteau Owned by: dwatteau
Priority: blocker Component: Engine: SAGA
Version: Keywords:
Cc: Game: I Have No Mouth

Description

ScummVM 2.7.0git-3a2cb7fee141f on any macOS system. IHNM is either the English or French Windows release from GOG.

When I'm running the latest development release on macOS, the game won't start anymore with this fatal error:

WARNING: ResourceContext::loadResV1(): Incorrect contextSize: 0 < 17!
WARNING: Cannot load context scream.res!

The scream.res file really is fine and the game properly worked a few weeks (months?) ago. I haven't bisected it yet, but I think this is quite likely to commit 7b9f0ab75daa4ce8862bbd36a06753df736fc5f3 ("SAGA: Switch from custom macbinary parser to MacResManager") or something around it.

What's strange is that MacResManager::isMacBinary() returns true for this resource, although it really isn't a Mac binary as far as I can tell... maybe it triggers a false positive for some reason?

I can't reproduce this problem on a Windows system.

Can't say if this is more of a SAGA or macresman.cpp issue...

Change History (2)

comment:1 by dwatteau, 19 months ago

Priority: normalblocker

Making it a blocker for 2.7.0 because it’s a recent regression on a major platform and for a pretty well-known game in our catalogue.

comment:2 by dwatteau, 19 months ago

Owner: set to dwatteau
Resolution: fixed
Status: newclosed

Fixed by PR#4600. Thanks!

Note: See TracTickets for help on using tickets.