Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#1370 closed defect (worksforme)

MANIAC: Can't water man-eating plant

Reported by: SF/mryeeshkul Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Maniac Mansion

Description

Hello, i played Maniac Mansion (enhanced) under W2000
via summ 051 and i have found these bugs so far:

1. Codes doesnt work at all, you can use a random
number to go through.
2. The MAN-eating plant doesnt react on water after
giving her pepsi. I mean it doesnt grove.
3. From some strange reason Bernard did not wanna give
the Badge to Dave (but it is not necessary, just a little
notice)
4. Anyone can finish the game even if Dave is alive
(which is maybe all right i dont know)

That's it, good luck and thanks a lot for doing that job!
Jan

Ticket imported from: #870090. Ticket imported from: bugs/1370.

Change History (8)

comment:1 Changed 15 years ago by fingolfin

Please, when reporting bugs, read the instructions on the bug
submission page first. In particular: "First, please check the
compatability list to ensure the bug is not already known.
Secondly, try out the latest CVS/daily build".
Doing so saves us work, and you some embarassment :-). Also, it
would be helpful if you only report one issue per item. But I
digress.

Re 1: Copy protection is disabled, hence any code will work. If you
really really want to have the copy protection, you can reenable if
you use latest CVS instead of 0.5.1 (you can grab a daily build for
Windows from our website)

Re 4: That's not a bug.

As for the other two, it would be very nice if you checked wether
they occur with latest CVs, too....

comment:2 Changed 15 years ago by fingolfin

Summary: I found these bugsMANIAC: I found these bugs

comment:3 Changed 15 years ago by SF/mryeeshkul

Hi, i tried to use the cvs version i got yesterday.
As for man-eating plant problem:
The Man-eating plant still refuses water. I tried to use "Give",
which targets the man-eating plant as a "Plant" and Dave
says he'd better get closer but nothing else. And i also
used "Use", when Dave behaves like doing something but no
result and water stays in the jar.
Jan

comment:4 Changed 15 years ago by SF/mryeeshkul

Summary: MANIAC: I found these bugsI found these bugs

comment:5 Changed 15 years ago by fingolfin

Summary: I found these bugsMANIAC: Can't water man-eating plant

comment:6 Changed 15 years ago by SF/voodoofx

If i understand you right, you first gave pepsi to man
eating plant, then tried to water it? From what i can
remember you had to water the plant FIRST, then use the
pepsi on it. And also i think you must use radioactive
water, not the normal one... try that, and report back.

comment:7 Changed 15 years ago by Kirben

I just checked with fresh game, using radiated water and
pepsi on plant still works fine with ScummVM cvs.

comment:8 Changed 15 years ago by Kirben

Owner: set to Kirben
Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.