Opened 15 years ago

Closed 15 years ago

#1361 closed defect (fixed)

FT: crash during intro

Reported by: SF/leerqbasic Owned by: eriktorbjorn
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Full Throttle

Description

ScummVM 0.5.7cvs (Dec 30 2003 00:30:08)
Full Throttle, English

During the intro, just after Mr. Corley exits his limo
to enter the bar and say: "All right, who's the guy
that drove over my car?", ScummVM crashes:

Video is set to finish
Fatal signal: Segmentation Fault (SDL Parachute Deployed)

I noticed that if ScummVM crashes, the message "Video
is set to finish" is likely to be there. Also, this bug
didn't occur before (like 3 days ago everything worked
like a charm).

Ticket imported from: #867078. Ticket imported from: bugs/1361.

Change History (6)

comment:1 Changed 15 years ago by eriktorbjorn

Owner: set to fingolfin

comment:2 Changed 15 years ago by eriktorbjorn

I comitted a quick-and-dirty fix for this earlier today, but
that was just to stop it from crashing. (It wasn't just the
intro that was crashing, it was any time someone spoke.
Except, of course, for the animated cutscenes.) I'm guessing
it should be fixed more thoroughly...

Assigning to Fingolfin, since I believe he made the change
that introduced the regression. (Between revisions 1.94 and
1.95 of imuse_digi.cpp)

comment:3 Changed 15 years ago by fingolfin

The change you made to CVS to fix that one FT crash is 100%
correct and complete. I don't see why anything else should be
changed there. The simple reason why it crasehd was that I had no
test cases when I made that change (and I still don't have any,
until I find my FT cd and reget monster.sou from it - I only have a
monster.so3 on my HD).

Also I currently can't even look into this bug, not near my
computer. Unassigning from me.

comment:4 Changed 15 years ago by fingolfin

Owner: fingolfin deleted

comment:5 Changed 15 years ago by eriktorbjorn

Owner: set to eriktorbjorn
Resolution: fixed
Status: newclosed

comment:6 Changed 15 years ago by eriktorbjorn

Mainly, I wasn't sure whether there were other case when we
needed to check 'ptr' before dereferencing it. But if you
say this is sufficient, I'll take your word for it and close
the bug.

Note: See TracTickets for help on using tickets.