Opened 16 years ago

Closed 15 years ago

Last modified 15 years ago

#1187 closed defect (wontfix)

DIG: Critter puzzle bug

Reported by: SF/gensuke Owned by: SF/ender
Priority: normal Component: Engine: SCUMM
Keywords: script Cc:
Game: The Dig

Description

ScummVM 0.5.1 (Aug 7 2003 00:29:29) (win32)
The Dig, English, Talkie

Load savegame 01 and click on the hole on your left:
Commander Low will say "There is something moving in
here!", but the critter is actually near you.
This will screw up the puzzle.

Ticket imported from: #794357. Ticket imported from: bugs/1187.

Attachments (1)

dig_s01.zip (24.6 KB) - added by SF/gensuke 16 years ago.
Savegame 01

Download all attachments as: .zip

Change History (9)

Changed 16 years ago by SF/gensuke

Attachment: dig_s01.zip added

Savegame 01

comment:1 Changed 16 years ago by SF/segra

Even though this bug does happen, the puzzle is still
completable, i just did it using this savegame, after clicking
on the hole

comment:2 Changed 16 years ago by SF/gensuke

The savegame represent one of the possible scenarios when
the script fails.

In this case after the critter runs away, you must exit the
area in order to look (and find it) in the hole again.

The worst scenario is represented when the critter enters one
of the hole and they are still lookable without exiting the
screen.

In this case everytime you look in the hole, the critter's
position will be shifted (he runs on rocks and so on) and the
puzzle will not be completable.

Anyway, even in the worst scenario, exiting the location reset
the script (that's why the bug's priority is set to 5), so it is
possible to complete it.

comment:3 Changed 16 years ago by fingolfin

Hum, I am not quite sure I see how this is a bug. Are you sure it's
not just your save game which is corrupt? If so, can you generate
a second save game with such brokeness?

BTW I can easily solve the puzzle in that savegame w/o ever
leaving the room. You say that it's "one of the possible scenarios",
can you provide any other (more serious) save games then?

comment:4 Changed 16 years ago by SF/gensuke

It is not a savegame problem, due to the fact that when i first
noticed the bug, I've restarted scumm VM loading a previous
savegame.

After a lot of tries, I was able to reproduce the scenario
shown in the attached savegame.

I don't know how the script works, but I assume there should
be a flag to know if the hole is empty or not (and if the critter
is out of it or not), so the savegame provided should be
enough to check against the usual values and to provide a fix.

I've tried to reproduce the other scenario that screws up the
puzzle due to position shifting of the critter actor, but I was
not able to reproduce it.

Anyway even in the worst case, the puzzle is still completable
upon reset (exiting the location), but it is still potentially
buggy. :)

comment:5 Changed 16 years ago by fingolfin

First off, just to avoid a misunderstanding: you wrote this in the
past: "In this case after the critter runs away, you must exit the
area in order to look (and find it) in the hole again". Not so! If I
click on that hole, indeed Low says "There is something moving in
here!" and then the critter indeed runs out of that hole. I.e. it
"magically teleported". Which is why I asked if the savegame
might be corrupt. If I then click on the hole a second time, Low
tells me that it only contains Junk. However, the critter
apparently is "teleported" once more. Still, despite this,
everything is easily completeable, w/o even leaving the room.

As to how the script works: I still have to analyze it. But it's sadly
not a matter to "check against the usual values" because we
don't even know what are usual values, obviously. There are a
myriad of possible causes for this "bug"

comment:6 Changed 16 years ago by SF/gensuke

I've checked the savegame, experimenting a little in order to
check when the critter is "teleported once more".

There are 3 holes:

- down left
- down right
- up right

The critter is "teleported once more" apparently after a
certain delay.

It seems that there are different delays depending on wich
hole you look into.

The down left hole seems to have the greatest one, I have to
wait a lot (at least on my machine) in order to see the critter
again, it is simpler to exit and reenter the location to reset the
puzzle.

I didn't notice this before, that's why I wrote that exiting the
location was needed.

About the "usual values" part, I mean the variables values the
script has when the clicked holes shows the "there is
something moving" and the critter is hidden versus the "there
is something moving" and the critter is already oin screen (or
the combination junk/critter onscreen).

comment:7 Changed 15 years ago by SF/ender

I'm closing this as a Wont Fix - it appears to be a script bug
that was present in the original. Perhaps it is simply differences
in timing that causes it to occur more frequently in ScummVM,
but it's not really a bug.

comment:8 Changed 15 years ago by SF/ender

Owner: set to SF/ender
Resolution: wontfix
Status: newclosed
Note: See TracTickets for help on using tickets.