Opened 16 years ago

Closed 15 years ago

Last modified 14 years ago

#1140 closed defect (fixed)

Agent Eduardo Dialogue doesn't appear - game unfinishable

Reported by: SF/choock Owned by:
Priority: normal Component: Engine: Sky
Keywords: Cc:
Game: Beneath a Steel Sky

Description

When you need to talk to Gardener in Park on Bottom
Level to move story forward nothing happens. It looks
like it loads the dialogue (mouse cursor dissapears). If
you wait several minutes mouse cursor reappears, but
dialogue option do not appear even after 30 mins. F5 still
works so you can restore older save.

Therefore the game is unfinishable (ScummVM 0.5.1)

Ticket imported from: #786482. Ticket imported from: bugs/1140.

Attachments (2)

Sky-vm.005 (52.5 KB ) - added by SF/choock 16 years ago.
savegame
Sky-vm.004 (52.3 KB ) - added by SF/choock 16 years ago.
older save (before bug)

Download all attachments as: .zip

Change History (18)

comment:1 by lavosspawn, 16 years ago

Hm?
Did you continue playing using an old 0.5.0 savegame?
Which BASS version are you using? Provide a savegame
please.

by SF/choock, 16 years ago

Attachment: Sky-vm.005 added

savegame

comment:2 by SF/choock, 16 years ago

I played everything under 0.5.1. BASS is CD version (options
fullscreen through mame3x filter). Savegame attached (at
least I hope sixth save slot has number 005 :) )

comment:3 by lavosspawn, 16 years ago

Actually, I was thinking of a savegame *before* the bug
occurs.
Is this bug reproducable? Have you done anything special to
make it occur?

by SF/choock, 16 years ago

Attachment: Sky-vm.004 added

older save (before bug)

comment:4 by SF/choock, 16 years ago

older savegame attache - unfortunately maybe too old...
AFAIR I did not anything special, but I did not use
walkthrough, so it's possible that I was somewhere a little
ahead with storyline.
I discussed everything with the boy with gameboy, did what I
could in the club, checked dandelions... I think the only thing
which was not necessary was the deletion of money from
account of factory supervisor

comment:5 by SF/lotodore, 16 years ago

I can confirm this bug. I started to play the game using
ScummVM 0.5.1 and I have the same bug. I did not use an old
savegame. This was really frustrating :-( because I hadn't
played the game before and I thought the gardener is not
important and I tried for hours to do weird things to make
the story move forward...

Need another savegame?

comment:6 by SF/jorpho, 16 years ago

I have also encountered this bug. I _think_ that in order to
cause it, you have to walk off the screen while Eduardo is still
standing, before he resumes tending to his plant. Sometimes
he takes much longer to resume than at other times.

(Here's a wild guess at what's happening: When you try to
talk to Eduardo, he finishes up his current animation sequence
and then turns around and starts talking. When you walk off
the screen, he never goes back to tending his plants, and
when you try to talk to him again, the program waits forever
for him to finish an animation sequence that he's no longer
performing.)

comment:7 by lavosspawn, 16 years ago

Hmm.. interesting.
@jorpho:
Yes, the gardener compact is indeed waiting for something.
Probably animation related, though I can't say for sure.
If walking out of the screen causes it, it means it's a script
bug... basically what I expected anyways. The animation
script for the Gardener is quite hacky... I'll see if I can work
around it.

comment:8 by SF/meste, 16 years ago

choock,

could you send me the save files on my address? I don't know
why I caanot DL them from here

serban.mestecaneanu@britishcouncil.ro

thanks,
meste

comment:9 by SF/qirien, 16 years ago

We also encountered this bug with the latest versions of
ScummVM and BaSS (from debian unstable; ScummVM v0.5.1, BaSS
v0.0368).

To reproduce this bug, find Anita's body, then talk to the
gardener and ask him about her. He says, "Maybe I know her,
maybe I don't". THEN get her card, and after you see her
hologram, go talk to him again, but there is no other
dialogue option about Anita, so you can never find out that
he is Eduardo.

If you need save games or anything, we can easily provide them.

comment:10 by SF/qirien, 16 years ago

Actually, it looks like this might be a slightly different
bug -- but an equally as debilatating one. Following the
steps I mentioned earlier will also make it so you can't ask
anyone about the subway -- as if it's not setting a
"seenHologram" type flag or something.

comment:11 by SF/monsieur_ouxx, 16 years ago

I think Jorpho is right.
The bug occurs when Eduardo stands as you leave the room.

The problem is that I had the bug anyway when I used both
your downloadable savegames.
Nevertheless, I took one of my an older savegames (where
Eduardo hadn't stood yet) and then I tried to be carefull to
leave the room only when he was sitting - And it worked !
I finished the game this way.

(I'm using CD version 0.0368)

comment:12 by SF/khalek, 15 years ago

bug #984095 has been marked a duplicate of this and closed

comment:13 by eriktorbjorn, 15 years ago

Did anyone ever manage to figure out exactly how to trigger
this bug? I mean, I can see that it happens with the
provided savegame, but I've never managed to get the
gardener stuck like that myself. If I walk off the screen
while he's standing up, he'll just turn back to the flowers
as soon as I re-enter.

comment:14 by lavosspawn, 15 years ago

Resolution: fixed
Status: newclosed

comment:15 by lavosspawn, 15 years ago

fixed. And it only took a little more than a year, so where's
the problem? =)

comment:16 by fingolfin, 14 years ago

Component: Engine: Sky
Game: Beneath a Steel Sky
Note: See TracTickets for help on using tickets.