Opened 16 years ago

Closed 16 years ago

Last modified 14 years ago

#1100 closed defect (fixed)

BASS gets stuck

Reported by: SF/arcticwolf Owned by: lavosspawn
Priority: high Component: Engine: Sky
Keywords: Cc:
Game: Beneath a Steel Sky

Description

* ScummVM version:

ScummVM 0.5.0 (Aug 2 2003 02:52:38)

* Bug details:

ScummVM gets stuck in an early scene of "Beneath a
steel sky", precisely, in the "test section" where
Anita is working after being reassigned by Lamb in the
game. This manifests itself in the following ways:

- Foster is permanently stuck in the middle of the screen.
- The words "Dummy message" are permanently displayed
above his head.
- A talk menu with the only option being "Never
mind..." is open; selecting that option causes Foster
to say that, but does not otherwise change the game's
state.
- Saving / loading is impossible.

Also see attached screenshot; "background action"
continues without problems, and music is also still
playing.

It's not clear to me whether the bug is reproducible; I
haven't tried to do so (mostly due to lack of a saved
game to use as a starting point).

* Language of game:

English.

* Version of game:

Floppy version, downloaded from ScummVM website.

* Platform and compiler:

Windows XP w/ SP1 (version 5.1.2600).

* Save game:

Saving the game is not possible.

* Last working version:

Unknown.

Ticket imported from: #782032. Ticket imported from: bugs/1100.

Attachments (1)

bass_stuck.gif (206.9 KB) - added by SF/arcticwolf 16 years ago.
Screen shot of stuck scene

Download all attachments as: .zip

Change History (9)

Changed 16 years ago by SF/arcticwolf

Attachment: bass_stuck.gif added

Screen shot of stuck scene

comment:1 Changed 16 years ago by SF/arcticwolf

Priority: normalhigh

comment:2 Changed 16 years ago by SF/toastee

This bug happens intermittently for me as well, Though Not
quite as severe, It usually crashes only if you offer joey a
new shell before meeting all the conditions to obtain the shell.

comment:3 Changed 16 years ago by fingolfin

Summary: 0.5.0 release: BASS gets stuckBASS gets stuck

comment:4 Changed 16 years ago by SF/ender

What's the status of this one?

comment:5 Changed 16 years ago by SF/ender

Owner: set to lavosspawn

comment:6 Changed 16 years ago by lavosspawn

It's load/save related. Will be fixed in 0.5.1

comment:7 Changed 16 years ago by lavosspawn

Resolution: fixed
Status: newclosed

comment:8 Changed 14 years ago by fingolfin

Component: Engine: Sky
Game: Beneath a Steel Sky
Note: See TracTickets for help on using tickets.