Opened 16 years ago

Closed 16 years ago

#1070 closed defect (fixed)

MM: Jail Door Closes

Reported by: SF/segra Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Maniac Mansion

Description

Latest CVS Version,

When you walk down to the reactor and unlock the door
using the old rusty key, the door opens. But when you
try and walk through the door the door closes.
You can walk away and its fine, but as soon as you try
and walk through the door it closes.

The game is still completable with this problem, its just
annoying at times.

Attached is a savegame at the door, just unlock and try
and enter.

Ticket imported from: #776807. Ticket imported from: bugs/1070.

Attachments (1)

maniac.s04 (56.2 KB ) - added by SF/segra 16 years ago.

Download all attachments as: .zip

Change History (7)

by SF/segra, 16 years ago

Attachment: maniac.s04 added

comment:1 by SF/segra, 16 years ago

Problem also occurs in original (non enhanced) version

comment:2 by SF/segra, 16 years ago

btw, the attached savegame is for the enhanced version.

comment:3 by Kirben, 16 years ago

Component: Engine: SCUMM
Game: Maniac Mansion

comment:4 by fingolfin, 16 years ago

The problem is this:
the sentence script of the door tries to close the door then put you
into the next screen. Visually that would look as if you are put into
the prison and then the door slams shut behind you.

To close the door, it uses doSentence - on the same object. So
that verb/sentence is executed, the door is closed, then the
sentence script is quit - quit completely! I.e. instead of returning
from the recursion, to finish its work (i.e. loading the next room)
it stops after closing the door. Which manifests as the problem we
see.

My guess is that our doSentence opcode in V2 still isn't quite right.
Also the "recursion" flag handling for V2 might be flawed .

comment:5 by SF/segra, 16 years ago

Line 1567 of script_v2.cpp is stopObjectScript(object,
recursive);

commenting out this line fix's this problem, it also fixs bug
#771483

Not sure if this is going to help you fix the problem or not,
just thought i would let you know ;)

comment:6 by fingolfin, 16 years ago

Owner: set to fingolfin
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.