Opened 16 years ago

Closed 13 years ago

#1030 closed defect (fixed)

ZAK: Pushing Sarcophagous feet on Mars

Reported by: SF/voodoofx Owned by: fingolfin
Priority: high Component: Engine: SCUMM
Keywords: script Cc:
Game: Zak McKracken

Description

ScummVM version: ScummVM 0.5.0pre-cvs Built on Jul
15 2003 11:47:01

Platform: win32(WinXP)
Zak version: EGA(V2 enhanced)
Language: english

Pushing sarcophagous feet on Mars should reveal a
secret door, however when i push the feet, they kick
back, so the door doesn't show up. This makes the game
again INCOMPLETABLE! Until next build, i guess :)

Savegame attached!

Ticket imported from: #771483. Ticket imported from: bugs/1030.

Attachments (2)

zak.s23 (52.7 KB ) - added by SF/voodoofx 16 years ago.
No door
zak.s30 (52.6 KB ) - added by SF/hoenicke 16 years ago.
German save game

Download all attachments as: .zip

Change History (24)

by SF/voodoofx, 16 years ago

Attachment: zak.s23 added

No door

comment:1 by SF/hoenicke, 16 years ago

Seems to be a walkbox problem. There is a workaround:

Click on the floor before the sarcophagous. Then press the feet.

comment:2 by SF/voodoofx, 16 years ago

Your trick works, game is completable now, however, i hope
this is temporary workaround and that it'll be fixed
eventually. :))

comment:3 by SF/ender, 16 years ago

Owner: set to fingolfin
Priority: normalblocker
Summary: Zak: Pushing Sarcophagous feet on Mars0.5.0 RC Zak: Pushing Sarcophagous feet on Mars

comment:4 by SF/ender, 16 years ago

There does indeed seem to be a walkbox problem there, as
Melissa seems to have problems walking around.

I'm pretty sure this is a regression too. Fingolfin, could
your latest Walkbox changes have affected Zak? I'm not
very familiar with that bit of code.

comment:5 by fingolfin, 16 years ago

What walkbox changes are you talking about? I didn't do any.

comment:6 by fingolfin, 16 years ago

Owner: fingolfin removed

comment:7 by SF/ender, 16 years ago

Didn't you do something related to Maniac recently?

I saw some commit about contingous walkboxes that you
reversed out in favor for some other fix.

Like I said, I dunno anything about this code, but I
thought you'd changed something recently?

comment:8 by fingolfin, 16 years ago

No I didn't. While you are right that I made a small mod to
boxes.cpp, I then (as you also noticed) reversed the change
immediately afterwards.

comment:9 by SF/ender, 16 years ago

Ok, I didn't know whether it'd been reversed for other
code changes that might relate to this.

If not, then I guess it's regression testing the old
fashioned way :P

comment:10 by fingolfin, 16 years ago

Since I don't have the english version of Zak, I can't look into this
using the supplied savegame, and frankly I don't feel like playing
till there manually. But maybe somebody has a savegame for the
german version of Zak?

by SF/hoenicke, 16 years ago

Attachment: zak.s30 added

German save game

comment:11 by fingolfin, 16 years ago

Priority: blockerhigh
Summary: 0.5.0 RC Zak: Pushing Sarcophagous feet on MarsZAK: Pushing Sarcophagous feet on Mars

comment:12 by fingolfin, 16 years ago

Status: newclosed

comment:13 by fingolfin, 16 years ago

Owner: set to fingolfin
Resolution: fixed

comment:14 by fingolfin, 16 years ago

I am reopening this, as my fix caused regression for the TPC
counter and probably other places (e.g. the airplane). Will have to
look for a better fix.

comment:15 by fingolfin, 16 years ago

Priority: highnormal
Status: closednew

comment:16 by SF/ender, 15 years ago

Max, do you remember what the problem was?

Raising priority, since its not just a cosmetic problem. Will also
add a to 'Known Bugs' section for 0.7.1

comment:17 by SF/ender, 15 years ago

Priority: normalhigh
Resolution: fixed

comment:18 by sev-, 13 years ago

What is the status of this item?

comment:19 by fingolfin, 13 years ago

The issue was still present last time I checked, and I strongly doubt that it's
gone now.

comment:20 by SF/joachimeberhard, 13 years ago

Yes, this issue is still there with various symptoms.

In ZakV1 for example, the kid drops back to the entrance
every time you change the room eg. walk to the door the
push has opened.

While you still can complete the game, its very annoying
to push the feet again and again for every character you
want to move in/out of the room.

Also, there's a walkbox problem in this room, as stated in
bug https://sourceforge.net/tracker/index.php?
func=detail&aid=1329523&group_id=37116&atid=418820

Also, this bug seems related:

https://sourceforge.net/tracker/index.php?
func=detail&aid=1329529&group_id=37116&atid=418820

Joachim

comment:21 by fingolfin, 13 years ago

Resolution: fixed
Status: newclosed

comment:22 by fingolfin, 13 years ago

Fixed in Subversion, next daily build should have the fix.

Note: See TracTickets for help on using tickets.