Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#1012 closed defect (fixed)

MONKEYEGA: No music when trainer says "The machine"

Reported by: SF/dfabulich Owned by: SF/hoenicke
Priority: normal Component: Engine: SCUMM
Keywords: script Cc:
Game: Monkey Island 1

Description

Go to the sword trainer with 30 pieces of eight and a
sword and get yourself trained. During the training
talk, he'll say that he needs to take drastic measures,
requiring him to bring out "The Machine." In the
normal version of the game, when he says this, there's
a musical cue ("du-DUM!"), but in ScummVM, there's no
music, and the dialogue text disappears very rapidly.

I'm using the Spanish EGA version on Win2K, ScummVM
0.5.0pre-cvs, Built on Jul 14 2003 03:24:03.

Ticket imported from: #770581. Ticket imported from: bugs/1012.

Attachments (1)

monkeyega.s01 (55.6 KB) - added by SF/dfabulich 16 years ago.
Click the first dialogue option to get trained

Download all attachments as: .zip

Change History (11)

Changed 16 years ago by SF/dfabulich

Attachment: monkeyega.s01 added

Click the first dialogue option to get trained

comment:1 Changed 16 years ago by SF/dfabulich

Uh, come to think of it, this is probably just a dupe of the
"no sound effects" bug for some games, including Monkey EGA,
Indy256 and Monkey VGA floppy (but not VGA CD). Note that I
DO get music in this game, just no sound effects... so I bet
that musical cue was just a sound effect that I'm not getting.

Is there a bug filed for the sound effects issues on these
games?

comment:2 Changed 16 years ago by Kirben

Could you recheck with recent ScummVM CVS version ? since
sound effects are now supported.

comment:3 Changed 16 years ago by SF/logicdeluxe

ScummVM 0.5.3cvs (Aug 17 2003 01:51:51)
This particular sfx sounds very wrong. It is supposed to be
a portamento.
The same sfx is used in indy3 when looking at the knight in
the catacombs. Also there it playes wrong the same way.

comment:4 Changed 16 years ago by Kirben

Could you attach a save game from English version ?
the Spanish one crashes here.

comment:5 Changed 16 years ago by SF/logicdeluxe

http://www.gratissaugen.de/files/machine.zip
It is a savegame from English VGA and it also includes the
sfx sampled from the original interpreter with a SB Live!.
So you could get the idea of what it should sound like.

comment:6 Changed 16 years ago by Kirben

Owner: set to SF/hoenicke

comment:7 Changed 16 years ago by fingolfin

What is the status of this item?

comment:8 Changed 16 years ago by Kirben

The sound effect still doesn't sound correct with ScummVM
cvs, I'm guessing there are timing differences in the sound
effects used by different games.

comment:9 Changed 16 years ago by SF/hoenicke

I just committed a fix that makes the sound effect much closer to
the original. The frequency is still wrong but I think the sound is
acceptable now.

Doing it completely right, would mean a bigger change to the
adlib backend. The way the frequency is currently communicated
to the backend is by converting it to a note. There is some
essential information lost on the conversion.

BTW, you can test the sound by typing "imuse play 50" in the
debug-console just after starting the game.

comment:10 Changed 16 years ago by SF/hoenicke

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.