Opened 13 months ago

Closed 13 months ago

Last modified 13 months ago

#14158 closed feature request (wontfix)

GRIM: Please add another german version CRCs

Reported by: nudgegoonies Owned by: aquadran
Priority: normal Component: Engine: Grim
Version: Keywords:
Cc: nudgegoonies Game: Grim Fandango

Description

I own this german budget release on 2 CDs in a double case with documentation on CD. It has the ISBN 4012160461009 and is sold here for example:

It is detected by residualvm as grim-win-de.

There are the following differences to the files in md5check:

  • MOVIE01 has b5a67c98be256eddaf731b39e0ceb8bd instead of 500bc51ce211d528f6c7170f479c9525
  • MOVIE03 has 85a720936044f99ea7c08522606349b8 instead of d2aae2e27616f78016a71818e528acda
  • DATA003 has the checksum of the englisch version and not of the german version that exists in md5check too
  • There is an additional DATA006 but it is the same size and checksum as DATA000 and scummvm starts the game with and without this file
  • There is an additional YEAR6MUS with the checksum afe761da4aadb58266006efad35ffd65 and scummvm does not start when this file is present and i end up in the console

This is my old github issue. At that time there were more changes than listed here but these are already included in md5check:
https://github.com/residualvm/residualvm/issues/796

Change History (8)

comment:1 by dwatteau, 13 months ago

Thank you for this information. Does the game properly works in ScummVM through all its chapters? It looks like there are some copy-protected European releases (I'm aware of a French one) that makes some chapters unplayable, so a confirmation that the full game works would be helpful, I think.

Thanks.

comment:2 by GermanTribun, 13 months ago

I can add something to copy protected intenational versions.

I know for damn sure that the original German retail release has a terrible copy protection scheme that aritifically ballooned up the file sizes to much greater than they actually were. That made copying the files for use in ResudialVM back then impossible, forcing me to buy the budget release from 2007 (which works fine under ScummVM), which has the copy protection removed.

My working German version is this one:
https://ogdb.eu/index.php?section=game&gameid=15295

The original German version, which has the nasty copy protection, is this one:
https://ogdb.eu/index.php?section=game&gameid=21109

The original poster's version seems to be this one:
https://ogdb.eu/index.php?section=game&gameid=1427

comment:3 by nudgegoonies, 13 months ago

It will take some time until i find the time to play it again. The most interesting part is, what content is in YEAR6MUS because scummvm crashes when it is there.

My version has copy protection too and it looks much like your version. There is a 679 Megabytes big CD.IDX file on CD 1 together with MOVIE01.LAB which is 453 Megabytes and MOVIE03.LAB which is 335 Megabytes. Altogether too much for CD. How have i copied it to my HD 20 years ago? I will lend a USB CD drive to check the CDs again and will report.

comment:4 by GermanTribun, 13 months ago

Yeah, CD.IDX and YEAR6MUS don't exist on the 2007 release, so they are clearly copy protection files. Also, the numbering in my version for game files only goes from 0 to 4. The unprotected MOVIE1.LAB only is 115 mb big, while MOVIE03.LAB is only 85.1 mb.

The fudging of file sizes makes all versions with said protection unusable.

Version 1, edited 13 months ago by GermanTribun (previous) (next) (diff)

comment:5 by dwatteau, 13 months ago

Thank you for your help!

It may be worth it to add detection code for the "broken" copy-protected releases, so that we can recognize them and tell users that they're unplayable, instead of letting them crash at some point. I wonder if the copy-protected releases always give the same hashes though, because sometimes copy-protected CDs would add random errors that would make the hash different each time, and in that case detecting them would be useless.

comment:6 by GermanTribun, 13 months ago

I found more discussions about that topic:

https://github.com/residualvm/residualvm/pull/845
https://github.com/residualvm/residualvm/issues/1173
https://github.com/residualvm/residualvm/issues/796
https://forums.scummvm.org/viewtopic.php?t=4307&highlight=grim+fandango+german&sid=f77a9cccc8efccd685dcae62f6aebbf2

The problem is well-known. The protection, apart from the extra dummy files that are not actually part of the game data, relies on forging the data table, making the file look much bigger to the OS than it actually is. That's something no longer allowed nowadays due to MS, but back then it was used.

comment:7 by aquadran, 13 months ago

Owner: set to aquadran
Resolution: wontfix
Status: newclosed

comment:8 by nudgegoonies, 13 months ago

Ok. So the protection is not only the bigger than CD size of the files but also error sectors within the MOVIE files that prevents copying the whole disc or the whole files. And the game accesses only those parts of the file that does not contain these errors.

I extracted the files with grim_unlab and there are 121 MB of snm files in MOVIE01 and 89 MB of snm files in MOVIE03.

By the way. The YEAR6MUS file contains two files named '1400 - start credits.imc' and '1401 - smooth hector.imc'.

Note: See TracTickets for help on using tickets.