Opened 2 years ago

Closed 11 months ago

Last modified 11 months ago

#13348 closed defect (fixed)

AGS: in certain games screenshots only show chosen elements

Reported by: lwcorp Owned by: lephilousophe
Priority: high Component: Engine: AGS
Version: Keywords: screenshots, OpenGL
Cc: Game:

Description (last modified by lwcorp)

In certain AGS games such as QFG2VGA and Kathy Rain only certain elements are saved in screenshots, meaning screenshots are unusable.

Compare the attached QFG2VGA screenshots (internal ones taken with alt+s and external with alt+print screen), including in the very first scene of the game.

Could it be related to #12438 or even the much less severe SCI issue #13767?

Attachments (5)

wit external.png (118.7 KB ) - added by lwcorp 2 years ago.
first scene external.png (126.2 KB ) - added by lwcorp 2 years ago.
first scene internal.png (110.0 KB ) - added by lwcorp 2 years ago.
wit internal.png (85.0 KB ) - added by lwcorp 2 years ago.
scummvm-kathyrain-00004.png (900.7 KB ) - added by Thunderforge 19 months ago.

Download all attachments as: .zip

Change History (17)

by lwcorp, 2 years ago

Attachment: wit external.png added

by lwcorp, 2 years ago

Attachment: first scene external.png added

by lwcorp, 2 years ago

Attachment: first scene internal.png added

by lwcorp, 2 years ago

Attachment: wit internal.png added

comment:1 by eriktorbjorn, 23 months ago

Does this still happen? I couldn't reproduce it with the current development version when I just tried it.

comment:2 by lwcorp, 23 months ago

Yes, it still happens, just reproduced it in v2.6.0git5160-g7b29c092086 (Apr 17 2022 04:49:50).

comment:3 by eriktorbjorn, 23 months ago

Odd, I still can't. I assume all I should have to do is to start the game and press Alt+S for a screenshot. (And I assume it's the remake by AGD Interactive.)

comment:4 by lwcorp, 23 months ago

Yes, but be sure to literally start the game (where you can walk around, talk, etc.), as saving the intro screens work. Look at the screenshots above to see how they look due to this bug vs taking them externally.

comment:5 by eriktorbjorn, 23 months ago

This time I walked around a bit before taking a screenshot, but I still couldn't reproduce it. I'm running ScummVM in Linux, and I tried both the "SDL Surface" and "OpenGL" graphics modes.

So I have no idea. Sorry.

comment:6 by lwcorp, 22 months ago

I've tried it in Windows, and it gets fixed if I manually use SDL Surface instead of Default or OpenGL. Although the game's screen is a lot smaller that way...

comment:7 by lotharsm, 21 months ago

Priority: blockerhigh

by Thunderforge, 19 months ago

Attachment: scummvm-kathyrain-00004.png added

comment:8 by Thunderforge, 19 months ago

This also happens in Kathy Rain (see attached screenshot, tested on Windows x64 2.6.0), so it's not unique to this game.

Last edited 19 months ago by Thunderforge (previous) (diff)

comment:9 by lwcorp, 19 months ago

Description: modified (diff)
Game: Quest for Glory 2
Keywords: OpenGL added
Summary: AGS: QFG2VGA screenshots show chosen elements onlyAGS: in certain games screenshots show chosen elements only

comment:10 by lwcorp, 19 months ago

Description: modified (diff)
Summary: AGS: in certain games screenshots show chosen elements onlyAGS: in certain games screenshots only show chosen elements

comment:11 by tag2015, 11 months ago

Owner: set to lephilousophe
Resolution: fixed
Status: newclosed

This should finally be fixed by
2c1741e

comment:12 by Thunderforge, 11 months ago

Confirmed: Kathy Rain and every other of the five AGS games I tried now produce proper screenshots.

Note: See TracTickets for help on using tickets.