#10555 closed enhancement (duplicate)

clarify subtitle speed direction

Reported by: lenhart Owned by: criezy
Priority: low Component: GUI
Keywords: text speed Cc: rappscallion@…
Game:

Description

I got a bit confused trying to lower the subtitle speed in Monkey Island because low numbers (slider left) mean high speed.
Didn't realize that until the next game, which means that the person playing missed quite some jokes and text while playing.

I found from the readme.md:

talkspeed number Text delay in SCUMM games, or text speed in

other games.

So it doesn't seem to be that easy to fix it with a simple reverse as different games interpret the variable differently.

Adding a line explaning which direction is which in which games might be the simplest solution. If someone knows something better..

The slider part is in:
https://github.com/scummvm/scummvm/blob/ec4e97dc235f95ea2a24637848d1f53a6ae1b56a/gui/options.cpp
named : "_subSpeedSlider"

I would like to (try to) contribute, but before I do something I would like to know what someone involved has to say to this.

The issue occured with Android and Linux ScummVm 2.0.0, just tried building the source (2.1.0) and it is the same.
(I hope i'll receive emails when something happens to this ticket, otherwise i left my mail too)

Change History (4)

comment:1 by criezy, 19 months ago

This looks like a duplicate of ticket #7722 in which you can see a discussion on the topic. That discussion was from 9 years ago, but not much has changed since then. What I suggested in that ticket was to add a label at each end of the slider, for example slow/fast for a speed slider to clarify its behaviour. You will see in that ticket that there was agreement that this particular slider is confusing, and that it would be nice to improve it.

comment:2 by lenhart, 19 months ago

Yes that's true. Unfortunately I haven't found the old ticket.

I think the unsatisfying part is that you have to write :
"fast for Scumm/lucas film games […] , slow for all others"
or is there a way to know at runtime which option is which in the gui?

or maybe just add a tooltip that if the speed doesn't change the way it is expected, try the other direction?

Version 0, edited 19 months ago by lenhart (next)

comment:3 by lenhart, 19 months ago

Resolution: duplicate
Status: newpending

comment:4 by criezy, 19 months ago

Owner: set to criezy
Status: pendingclosed

My suggestion would still be the same as what I wrote 9 years ago: make it a subtitle speed for all engines in the Options dialog, which would mean that the value need to be reversed to a delay inside the scummvm engine when reading the talk speed config value. Then we have consistency, which hopefully makes it less confusing to the user, and handling the label becomes simpler. However, see the caveats listed by fingolfin in bug #7722. If you are interested in working on this, please use bug #7722 for further comments. And you are welcome to pop up on our #scummvm IRC channel on freenode to discuss with us.

Note: See TracTickets for help on using tickets.