Ticket #8464: scummvm.spec

File scummvm.spec, 6.8 KB (added by wjp, 19 years ago)

scummvm.spec

Line 
1#------------------------------------------------------------------------------
2# scummvm.spec
3# This SPEC file controls the building of ScummVM RPM packages.
4#------------------------------------------------------------------------------
5
6#------------------------------------------------------------------------------
7# Prologue information
8#------------------------------------------------------------------------------
9Name : scummvm
10Version : 0.8.0
11Release : 1
12Summary : Graphic adventure game interpreter
13Group : Interpreters
14License : GPL
15
16Url : http://www.scummvm.org
17
18Source : %{name}-%{version}.tar.bz2
19Source1 : libmad-0.15.1b.tar.bz2
20Source2 : mpeg2dec-0.4.0b.tar.bz2
21BuildRoot : %{_tmppath}/%{name}-%{version}-root
22
23BuildRequires: desktop-file-utils
24BuildRequires: libogg-devel
25BuildRequires: libvorbis-devel
26BuildRequires: flac-devel
27BuildRequires: zlib-devel
28BuildRequires: nasm
29BuildRequires: SDL-devel >= 1.2.2
30
31#------------------------------------------------------------------------------
32# Description
33#------------------------------------------------------------------------------
34%description
35ScummVM is an interpreter that will play graphic adventure games written for
36LucasArts' SCUMM virtual machine, Adventure Soft's Simon the Sorcerer 1 and 2,
37Revolution Software Ltd's Beneath a Steel Sky and Renegade Software's
38Flight of the Amazon Queen. It uses the SDL library for outputting graphics.
39
40#------------------------------------------------------------------------------
41# install scripts
42#------------------------------------------------------------------------------
43%prep
44%setup -q -a 1 -a 2 -n scummvm-%{version}
45mkdir tmp
46
47%build
48(cd libmad-0.15.1b; ./configure --enable-static --disable-shared --prefix=%{_builddir}/scummvm-%{version}/tmp; make; make install)
49(cd mpeg2dec-0.4.0; ./configure --enable-static --disable-shared --prefix=%{_builddir}/scummvm-%{version}/tmp; make; make install)
50./configure --with-mad-prefix=%{_builddir}/scummvm-%{version}/tmp --with-mpeg2-prefix=%{_builddir}/scummvm-%{version}/tmp
51make
52
53%install
54install -m755 -D scummvm %{buildroot}%{_bindir}/scummvm
55install -m644 -D scummvm.6 %{buildroot}%{_mandir}/man6/scummvm.6
56install -m644 -D scummvm.xpm %{buildroot}%{_datadir}/pixmaps/scummvm.xpm
57desktop-file-install --vendor scummvm --dir=%{buildroot}/%{_datadir}/applications scummvm.desktop
58
59%clean
60rm -Rf ${RPM_BUILD_ROOT}
61
62#------------------------------------------------------------------------------
63# Files listing.
64#------------------------------------------------------------------------------
65%files
66%defattr(0644,root,root,0755)
67%doc AUTHORS README NEWS COPYING
68%attr(0755,root,root)%{_bindir}/scummvm
69%{_datadir}/applications/*
70%{_datadir}/pixmaps/scummvm.xpm
71%{_mandir}/man6/scummvm.6*
72
73#------------------------------------------------------------------------------
74# Change Log
75#------------------------------------------------------------------------------
76%changelog
77* Mon Dec 20 2004 (0.7.0)
78 - added AUTHORS file
79* Thu Jul 15 2004 (0.6.0-2)
80 - added .desktop file (modified from patch 891909)
81 - used some elements of the .spec file for scummvm from http://livna.org/
82* Mon Mar 15 2004 (0.6.0)
83 - included libmad and libmpeg2
84* Sat Aug 02 2003 (0.5.0)
85 - Enhanced versions of Maniac Mansion and Zak McKracken are now supported and completable
86 - Beneath A Steel Sky is now supported and completable
87 - Added support for Amiga version of Monkey Island 1
88 - Initial unplayable support for V1 version of Maniac Mansion/Zak McKracken
89 - Curse of Monkey Island (COMI) support for playing from CD improved on Mac OS X
90 - Loading COMI savegames for disk 2 doesn't anymore require disk 1 first
91 - Rewritten iMUSE enginee, and many Music fixes (exp. Monkey Island 2)
92 - Support for music in Humongous games and simon2dos/simon2talkie (XMIDI format)
93 - Support for music in simon1demo (Proprietary format)
94 - Complete music support for Simon the Sorcerer 2
95 - Improved music and sound support in Zak256
96 - Added Aspect Ratio option
97 - Many other bug fixes, improvements and optimisations
98* Sun May 25 2003 (0.4.1)
99 - Added AdvMame3x filter
100 - Fixed crash in Curse of Monkey Island (and possibly other games as well)
101 - Fixed airport doors in Zak256
102 - Fixed crash in SDL backend
103 - Fixed various iMuse bugs
104* Sun May 11 2003 (0.4.0)
105 - Curse of Monkey Island (comi) support (experimental)
106 - Added support for the EGA versions of Loom, Monkey Island and Indy3
107 - Improved music support in Indy3 and the floppy versions of Monkey Islands
108 - Many Simon the Sorcerer 1 & 2 improvements and fixes
109 - Very pre-alpha Beneath a Steel Sky code. Don't expect it to do anything.
110 - Even more pre-alpha support for V2 SCUMM games (Maniac Mansion and Zak)
111 - Preliminary support for early Humongous Entertainment titles (very experimental)
112 - New debug console and several GUI/Launcher enhancements
113 - New Save/Load code (easier to expand while retaining compatibility)
114 - DreamCast port now works with new games added for 0.3.0b
115 - New official PalmOS port
116 - Various minor and not so minor SCUMM game fixes
117 - Large memory leak fixed for The Dig/ComI
118 - SMUSH code optimised, frame dropping added for slower machines
119 - Code cleanups
120* Sun Dec 01 2002 (0.3.0)
121 - massive cleanup work for iMUSE. Sam and Max music now plays correctly
122 - many bugfixes for Zak256, + sound and music support
123 - music support for Simon the Sorcerer on any platform with real MIDI
124 - experimental support for Indy3 (VGA) - Indiana Jones + Last Crusade
125 - completed support for Monkey1 VGA Floppy, The Dig
126 - added akos16 implementation for The Dig and Full Throttle costumes
127 - added digital iMUSE implementation for The Dig and Full Throttle music.
128 - Loom CD speech+music syncronisation improved greatly
129 - added midi-emulation via adlib, for platforms without sequencer support
130 - code separation of various engine parts into several libraries
131 - several fixes to prevent Simon the Sorcerer crashing and hanging
132 - hundreds of bugfixes for many other games
133 - new SMUSH video engine, for Full Throttle and The Dig
134 - new in-game GUI
135 - launcher dialog
136* Sun Apr 14 2002 (0.2.0)
137 - core engine rewrite
138 - enhanced ingame GUI, including options/volume settings.
139 - auto-save feature
140 - added more command-line options, and configuration file
141 - new ports and platforms (MorphOS, Macintosh, Dreamcast, Solaris, IRIX, etc)
142 - graphics filtering added (2xSAI, Super2xSAI, SuperEagle, AdvMame2x)
143 - support for MAD MP3 compressed audio
144 - support for first non-SCUMM games (Simon the Sorcerer)
145 - support for V4 games (Loom CD)
146 - enhanced V6 game support (Sam and Max is now completable)
147 - experimental support for V7 games (Full Throttle/The Dig)
148 - experimental support for V3 games (Zak256/Indy3)
149* Sun Jan 13 2002 (0.1.0)
150 - loads of changes
151* Fri Oct 12 2001 (0.0.2)
152 - bug fixes
153 - save & load support
154* Mon Oct 8 2001 (0.0.1)
155 - initial version
156