Opened 21 months ago

Closed 21 months ago

Last modified 21 months ago

#9993 closed defect (fixed)

TITANIC: Liftbot Doesn't want to talk after facing floor Level

Reported by: dafioram Owned by: dreammaster
Priority: normal Component: Engine: Titanic
Keywords: Cc:
Game: Starship Titanic

Description

OS: Win7-64
Game: Titanic GOG version c
ScummVM: 1.10.0git-4054-g96a1b70

When in the lift that has the liftbot if you face the the opposite side from the liftbot, where the floor level is, then turn away you will not longer be able to talk to the liftbot. It will say that "There is no one here to talk to".

To reproduce:

  1. Go into a liftbot elevator
  2. Look at floor number
  3. Look left or right
  4. Now you can't talk to the liftbot

So while you are facing the lift level you can still talk to him, but as soon as you look away, and from then on your can't. You can always go out of the elevator and back in and it resets.

The original engine doesn't do this.

Another difference at the same spot, in the original engine if you look at the floor level the game opens the operations tab (the middle one) of the PET while in scummvm it does not. Maybe thats related.

Attachments (2)

Untitled.png (235.9 KB) - added by dafioram 21 months ago.
No one here
titanic-win-1.003 (107.5 KB) - added by dafioram 21 months ago.
before going into lift

Download all attachments as: .zip

Change History (4)

Changed 21 months ago by dafioram

Attachment: Untitled.png added

No one here

Changed 21 months ago by dafioram

Attachment: titanic-win-1.003 added

before going into lift

comment:1 Changed 21 months ago by dreammaster

Owner: set to dreammaster
Resolution: fixed
Status: newclosed

Okay. I've the lost of 'NPC to talk to', as well as some other things I noticed whilst working on it. As for your 'opens the operations tab', I couldn't replicate anything like that happening when I tried the original. Unless you meant that the Call Lift remote action wasn't getting selected automatically when approaching a lift from the outside? In which case that's now fixed as well.

comment:2 Changed 21 months ago by dafioram

Nice.

I thought that the original game was switching your pet to the "REMOTE THINGUMMY" when you looked at the floor level in the elevator and scummvm wasn't, but it turns out that Elevator 3 doesn't do this while Elevator 4 does, in both scumvmm and the original. So I was checking elevator 3 in scummvm and elevator 4 in the original. They are doing the same thing.

Note: See TracTickets for help on using tickets.