Opened 5 years ago

Closed 4 weeks ago

#9987 closed defect (worksforme)

SCI: SQ5: Spacebar Pathing Issues

Reported by: dafioram Owned by: bluegr
Priority: low Component: Engine: SCI
Version: Keywords:
Cc: Game: Space Quest 5

Description

ScummVM: 1.10.0git-4029-g5c853fb
Tester OS: Win7-64
Game: Space Quest 5 DOS v1.04

In the spacebar area, when walking from the right side to the top or from the top to the right the path the character takes may have extra loops added or take a really long path to get somewhere close by.

The closer you are to the elevated area the more likely to reproduce it.

See Demo: https://streamable.com/7kxxe

I also encountered another pathing in the issue when going from the left side of the area to the right, but that one is not as easy to reproruce as the ones shown in the video.

Attachments (2)

sq5.028 (38.4 KB ) - added by dafioram 5 years ago.
spacebar
Paths.png (76.9 KB ) - added by dafioram 5 years ago.
Illustrations of the areas in which weird pathings can happen. The Black area is reproducible and red area is not such much.

Download all attachments as: .zip

Change History (4)

by dafioram, 5 years ago

Attachment: sq5.028 added

spacebar

by dafioram, 5 years ago

Attachment: Paths.png added

Illustrations of the areas in which weird pathings can happen. The Black area is reproducible and red area is not such much.

comment:1 by csnover, 4 years ago

Keywords: sci removed

comment:2 by bluegr, 4 weeks ago

Owner: set to bluegr
Resolution: worksforme
Status: newclosed

I can't reproduce this, I've tried clicking everywhere in the areas that are marked as problematic and Roger walks normally. I've tried clicking on the edge of the elevated area, starting off close to the elevated area, and all other possible combinations.

Seems that the issue either got fixed in the meantime, or it's a very edge case that it's not worth fixing.

Closing as worksforme

Note: See TracTickets for help on using tickets.