Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#9981 closed defect (wontfix)

MOHAWK: Riven: Button on station pedestal doesn't animate when pressed.

Reported by: macca8 Owned by: bgK
Priority: normal Component: Engine: Mohawk
Keywords: Cc:
Game: Riven

Description

On Garden Island, at the lower maglev station, pressing the button on the pedestal plays the sound effect, but not the video, of the button being pressed. This behaviour applies if summoning the maglev, and also if pressed after the maglev has arrived.

The attached saved game allows testing of both cases. Note that when summoning the maglev, there's an intentional 16 second delay before the maglev's arrival.

For reference, the button animates correctly (sound & video) when pressed at all other pedestal sites across the islands.

This glitch is also present in the original.

Current Daily Build: 1.10.0git4020-g87d32c2 (Jul 21 2017)
Game Version: English, 5-CD (contains v1.02 patch files)
Platform: Intel Mac (OS X 10.6.8)

Attachments (1)

riven-006.rvn (18.5 KB) - added by macca8 2 years ago.
Garden Island lower maglev station... press button.

Download all attachments as: .zip

Change History (3)

Changed 2 years ago by macca8

Attachment: riven-006.rvn added

Garden Island lower maglev station... press button.

comment:1 Changed 2 years ago by bgK

Owner: set to bgK
Resolution: wontfix
Status: newclosed

Thanks for your report. Unfortunately the video for the pedestal being pressed is missing. I can't really fix this.

The DVD version does have the video, and it is played correctly.

comment:2 Changed 2 years ago by macca8

Thanks bgK. Always a bit of a longshot. I appreciate your efforts.

Note: See TracTickets for help on using tickets.