Opened 2 years ago

Closed 2 years ago

#9974 closed defect (fixed)

SCI: Phant1: Frame Skips During Chase Carno's Room

Reported by: dafioram Owned by: csnover
Priority: low Component: Engine: SCI
Keywords: sci32 Cc:
Game: Phantasmagoria 1

Description

Tester OS: Win7-64
ScummVM: 1.10.0git-3986-gc3f8f1a
Game: Phant1 GOG CD/DOS 1.000.001UK English

During the final chase once you get into Carno's room and close the door the game skips a few frames. You might have to die once and restart.

My cpu usage is nominal during the freezing. The audio also plays fine.

I'm not sure if its a bug, but if you load my saved game with the chase save phant1 will delete it on start up, so you have to start before the chase.

Demo: https://streamable.com/onoph

Attachments (1)

save_game.zip (890 bytes ) - added by dafioram 2 years ago.
chp7 before end game

Download all attachments as: .zip

Change History (3)

by dafioram, 2 years ago

Attachment: save_game.zip added

chp7 before end game

comment:1 by dafioram, 2 years ago

The lag/frame skip is not reproducible in DOSBOX. Scummvm lags the same amount if you are doing the video in half screen or Full screen (an option within the phant1 game).

Last edited 2 years ago by dafioram (previous) (diff)

comment:2 by csnover, 2 years ago

Owner: set to csnover
Resolution: fixed
Status: newclosed

Thanks for your report! Patches to address this issue have been added in 8d32353394ce4aa750e54becc3f2d2e375b3963d, 0beb259278dfd18757bf9484a6123edf4b44864e, and 3d92f05261fbbfbb491ed855ed06167ab94ad3d3, and will be available in nightly builds 1.10.0git-4067 and later.

Note: See TracTickets for help on using tickets.