#9963 closed defect (fixed)

TITANIC: Incorrect Doorbot rendering during prologue

Reported by: dreammaster Owned by: dreammaster
Priority: normal Component: Engine: Titanic
Keywords: Cc:
Game: Starship Titanic

Description

During the prologue, just after you say "YES", the Doorbot briefly shows incorrectly. The problem is that a "double take" sequence is being done twice, part of which is a reverse playback of the double-take animation. The AVI in question is the only AVI I know in the game that has multiple frames for transparencies in the second AVI video track. Most others just have a track with a single static transparency.

So the problem is that in this case, the recently added code for reverse AVI playback isn't using the correct corresponding transparency frame for each frame of the main video track, resulting in weird partial renderings of the Doorbot.

Change History (1)

comment:1 Changed 20 months ago by dreammaster

Owner: set to dreammaster
Resolution: fixed
Status: newclosed

Finally \o/

Note: See TracTickets for help on using tickets.