Opened 22 months ago

Closed 22 months ago

Last modified 22 months ago

#9959 closed defect (fixed)

Discworld 2: Bug in the showing of "string sets"

Reported by: PetrCejpek Owned by: dreammaster
Priority: normal Component: Engine: Tinsel
Keywords: string quotes Cc:
Game: Discworld II

Description (last modified by wjp)

Greetings,
I am working on the Czech translation for Discworld 2: Missing presumed. I came across to following bug.

Every text quote in the ENGLISH1.txt and ENGLISH2.txt files is introduced by character which ascii number corresponds to the length of the following string. Some sets of strings are introduced by two characters where the value of the first one is 8x (hexadecimal) and x corresponds to the number of strings in the set. I am guessing it wants to tell that the whole string set has only one sound quote or something like that.

Example:

**‚X**I mean - it seemed we might have
a few mutual talking points -
information to exchange -
**8**pleasantries -
something in common -
that sort of thing.

Here, **‚X** what is 82 58 in hexadecimal means, that the set has two strings and the first one has length of 88 (58 hexadecimaly).

Unfortunately, I found out that ingame this works well only within interviews with other NPCs. When I try to talk about items in the inventory, it shows only the first string.

Example:

**‚l**I'd taste-test this stuff, but the
animation budget won't stretch to a
proper demonstration of the results -
**B**so you're just going to have to
take it on faith for this one, OK?

Again, it begins with **,** (82), therefore it should show two-string quote. But as the result the game shows:

I'd taste-test this stuff, but the
animation budget won't stretch to a
proper demonstration of the results -
and then Rincewind suddenly stops talking.

Details of the configuration:
Scummvm 1.9.0.2
Discworld 2: Missing Presumed (English)
Windows 7 or 10

Attachments (3)

dw2.031 (2.6 KB) - added by PetrCejpek 22 months ago.
Example 1
dw2.032 (2.2 KB) - added by PetrCejpek 22 months ago.
Example 2
dw2.033 (2.4 KB) - added by PetrCejpek 22 months ago.
Example 3

Download all attachments as: .zip

Change History (12)

comment:1 Changed 22 months ago by wjp

Description: modified (diff)

comment:2 Changed 22 months ago by dreammaster

Correct me if I'm wrong, but this sounds more like a feature request than a bug. You haven't specified which of the existing language versions actually make use of this and aren't working correctly. If it is new functionality, it may be harder to support that than if it was supposed to be existing behaviour that's legitimately broken.

comment:3 Changed 22 months ago by PetrCejpek

My default version of Discworld 2 is English (GB). Above mentioned behaviour shouldn't have anything to do with my changes, because it remains even when I try it with original English1.txt and English2.txt files.¨

I tried it even with the different versions of scummvm, but it doesn't help.

comment:4 Changed 22 months ago by dreammaster

"because it remains even when I try it with original English1.txt and English2.txt files.¨". Your reply is a bit ambiguous. Can you provide exact steps for reproducing the problem in the English version in-game? ie. talk to X, click on Y element, etc.

comment:5 Changed 22 months ago by PetrCejpek

Ok. Here are some examples:

Act 2, talking with suffrajester in the University garden (conversation starter, mounth symbol):

String set:
Still, all in all, we will not be
moved involuntarily -

except by calls of nature,
calls of super nature,

or through other extraneous
circumstances that we can't really control.

This works fine. Another example:
Act 3, talking to Susan (conversation starter):

String set:
I mean - it seemed we might have
a few mutual talking points -
information to exchange -

pleasantries -
something in common -
that sort of thing.

Works fine as well.

Examples of not working things:

Act 1, Right-click on the Chilli powder in the inventory.

String set:

I'd taste-test this stuff, but the
animation budget won't stretch to a
proper demonstration of the results -

so you're just going to have to
take it on faith for this one, OK?

Ingame, it shows only the first quote.

Act 3, Righ-click on the Black candle in the inventory:

String set:
Should look good on a
sinister black coffee table

next to a sinister black
"Hovel Improvement" magazine.

Again, it show only the first quote.

comment:6 Changed 22 months ago by dreammaster

Thanks for the examples. Do you have handy savegames you could attach for those points in the game?

Changed 22 months ago by PetrCejpek

Attachment: dw2.031 added

Example 1

Changed 22 months ago by PetrCejpek

Attachment: dw2.032 added

Example 2

Changed 22 months ago by PetrCejpek

Attachment: dw2.033 added

Example 3

comment:7 Changed 22 months ago by PetrCejpek

Saves with examples attached.

comment:8 Changed 22 months ago by dreammaster

Owner: set to dreammaster
Resolution: fixed
Status: newclosed

Thanks for information. I was able to identify and fix the problem.

comment:9 Changed 22 months ago by PetrCejpek

Nice to hear. Thanks. :-)

Note: See TracTickets for help on using tickets.