Opened 2 years ago

Closed 2 years ago

#9957 closed defect (fixed)

SCI: PHANT1: Chapter 7 - Palette glitch in basement

Reported by: csnover Owned by: csnover
Priority: high Component: Engine: SCI
Keywords: sci32 Cc:
Game: Phantasmagoria 1

Description

Similar to #9788.

Reproduction:

  1. Teleport to room 20210
  2. Set game day to 7 (vv g 106 7)
  3. Exit through the door to room 20200.

Expected: Palette is rendered correctly
Actual: Bad palette corrupts the background picture

This is caused by view 3171 being drawn at the same origin as the background picture, and being created later than pic 20200 screen items. In SSCI this view usually ends up getting a lower priority MemID so ends up sorting below the pic, but in ScummVM, the view is created later than the pic SI so sorts above it, causing its palette to be sent after the pic’s palette & leading to graphics corruption.

Change History (2)

comment:1 by csnover, 2 years ago

Owner: set to csnover

comment:2 by csnover, 2 years ago

Resolution: fixed
Status: newclosed

This should be fixed in b1b18c54f3fca42fb47295886b76d0fa948ad519.

Note: See TracTickets for help on using tickets.