Opened 22 months ago

Closed 4 months ago

#9956 closed enhancement (fixed)

SCI: LB2: No Lip Animation for Laura with Yvette about Tut

Reported by: dafioram Owned by: sluicebox
Priority: low Component: Engine: SCI
Keywords: original has-pull-request Cc:
Game: Laura Bow 2: The Dagger of Amon-Ra

Description

ScummVM: 1.10.0git-3766-gb0ecbc9 64bit
Game: Laura Bow 2 CD/DOS/English GOG v1.1
OS: Win7-64

Similar to #9950 and #9955.

When Laura talks to Yvette about Tut, Laura will have voice, but no lip animation.

Probably in original interpreter.

Attachments (1)

laurabow2-cd.025 (40.5 KB) - added by dafioram 22 months ago.
go to center area and talk to Yvette about tut

Download all attachments as: .zip

Change History (6)

Changed 22 months ago by dafioram

Attachment: laurabow2-cd.025 added

go to center area and talk to Yvette about tut

comment:1 Changed 20 months ago by csnover

Keywords: sci removed

comment:2 Changed 6 months ago by digitall

Keywords: original added

comment:3 Changed 6 months ago by sluicebox

Wow they really had trouble with this message, this is it's third bug. (#10723 and #10724)

The problem is that the game doesn't include a sync resource for Laura's message. Her lips also don't move in the original. ScummVM logs a warning about the missing resource. This is unrelated to bugs #9950 and #9955 which appear to just be poor quality lip sync data and I doubt anything can be done about.

But this one can be fixed. This message's buggy history means that there's a duplicate message tuple with the same text and same audio which is used later and it does include a sync resource. I'm submitting a patch that uses that sync resource for both message tuples.

https://github.com/scummvm/scummvm/pull/1373

comment:4 Changed 6 months ago by digitall

Keywords: has-pull-request added

comment:5 Changed 4 months ago by sluicebox

Owner: set to sluicebox
Resolution: fixed
Status: newclosed

The fix has been merged into master

Note: See TracTickets for help on using tickets.