Opened 22 months ago

Closed 19 months ago

Last modified 5 months ago

#9946 closed defect (fixed)

OPENGL: Entering fullscreen mode in GUI misbehaves in OpenGL mode on MacOS

Reported by: angstsmurf Owned by: criezy
Priority: normal Component: Port: Mac OS X
Keywords: Cc:
Game:

Description

This is related to #9945, but I think it deserves its own separate issue: if you enter fullscreen in the options tab of the GUI, after starting in windowed mode, the GUI will sometimes be offeset partly off-screen rather than centered, i,e. part of it is cut off. I think this happens when the GUI window is not centered when switching mode. And again, only in OpenGL mode.

When experimenting with this, I also got this possibly related console message:
WARNING: Widget <Launcher.Version> has clipping area x + w > 320 (640)!
WARNING: Widget <Launcher.Version> has clipping area y + h > 240 (480)!

Change History (10)

comment:1 Changed 21 months ago by csnover

Resolution: worksforme
Status: newpending

As with the other ticket I am having difficulty reproducing this, so a specific set of reproduction instructions to cause the bug would be very helpful.

comment:2 Changed 21 months ago by angstsmurf

Like #9945, this is with ScummVM 1.10.0git3962-g850dcdbdf8 and MacOS Sierra 10.12.5, on a Retina MacBook
Pro, 15 inch, mid 2014.

Start ScummVM in OpenGL, Modern theme, windowed mode. Make sure that Fullscreen option is off. Start any game (so far, I've tested with Riven, King's Quest VII, Gabriel Knight and Starship Titanic). It starts up and runs in a small window. Hit Alt+Enter to enter fullscreen mode. Hit Alt+Enter again to leave fullscreen mode. Now the window is twice as large as before.

EDIT: These reproduction steps apply to #9945, not #9946, and were entered here by mistake.

Last edited 19 months ago by angstsmurf (previous) (diff)

comment:3 Changed 19 months ago by csnover

A similar issue was reported and fixed in #9971. Are you still experiencing this bug in the latest daily builds?

comment:4 Changed 19 months ago by angstsmurf

I'm afraid it still happens here with 1.10.0git5099-ga51fb1f3b6.

Last edited 19 months ago by angstsmurf (previous) (diff)

comment:5 Changed 19 months ago by angstsmurf

These are the exact steps I use to reproduce it:
* Make sure the launcher is windowed by default (I do this by launching in fullscreen mode, setting fullscreen to off in options and quitting)
* Start the launcher in windowed mode (the launcher window will be small and centered), select options and tick the fullscreen option. Click OK.
* The launcher will enter fullscreen and look fine at first, but after a second or so it will be offset to the upper right, cutting off large parts of the launcher and leaving black space to the left and below.

Last edited 19 months ago by angstsmurf (previous) (diff)

comment:6 Changed 19 months ago by angstsmurf

Heh, I updated SDL to 2.0.6 and recompiled, and now the bug seems to be gone. Sorry about that!

Last edited 19 months ago by angstsmurf (previous) (diff)

comment:7 Changed 19 months ago by criezy

Can you indicate which version of SDL you were using before updating to SDL 2.0.6? If this is a bug in SDL it would be sueful to know which version not to use when I generate the next reelase ;)

Note: For me SDL 2.0.5 works properly on macOS X 10.12.

comment:8 Changed 19 months ago by angstsmurf

I was using SDL 2.0.5 before. Just like #9945, this might only occur on Retina/HiDPI screens.

Last edited 19 months ago by angstsmurf (previous) (diff)

comment:9 Changed 19 months ago by criezy

Owner: set to criezy
Resolution: worksformefixed
Status: pendingclosed

OK, thank you. From this feedback we will assume then that this is a bug in SDL2 with retina displays and that it is fixed in SDL 2.0.6.
I have just updated my toolchain for the release to use SDL 2.0.6, so hopefully the next release will work correctly.

comment:10 Changed 5 months ago by digitall

Component: --Unset--Port: Mac OS X
Note: See TracTickets for help on using tickets.