Opened 2 years ago

Closed 2 years ago

#9916 closed defect (fixed)

MOHAWK: Myst: Piano Weird Sounding Modulation

Reported by: dafioram Owned by: bgK
Priority: low Component: Engine: Mohawk
Keywords: Cc:
Game: Myst

Description

ScummVM 1.10.0git-3735-g065dd96 64bit
Game: Myst ME (10th-Anniversary), English, Windows
OS: Windows 7, 64bit

The piano works as intended if you press a key and hold it there.

If you move your mouse while clicking, but stay on the same key it will modulate the sound a bit (unexpected behavior) and if you drag it across multiple keys it also sounds weird.

Video: https://streamable.com/nrvyo

Attachments (1)

myst-011.mys (280 bytes ) - added by dafioram 2 years ago.
save

Download all attachments as: .zip

Change History (2)

by dafioram, 2 years ago

Attachment: myst-011.mys added

save

comment:1 by bgK, 2 years ago

Owner: set to bgK
Resolution: fixed
Status: newclosed

Thanks for the bug report. Commit c4207ad fixes the issue where the sound effect is restarting when moving the mouse.

Note: See TracTickets for help on using tickets.