Opened 2 years ago

Closed 12 months ago

#9906 closed defect (fixed)

SCI: LB1: Game hangs when examining bottle if walking in wrong spot

Reported by: sluicebox Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: has-pull-request Cc:
Game: Laura Bow 1: The Colonel's Bequest

Description

This is just like #9870, a bug in the original game that will freeze if you enter a command when you're standing in the right place while walking. See that bug for more details.

In this case, the command is "look bottle with monocle" when you're up against the trash can that the bottle is in. Like the other bug, it can be reproduced by turning the game speed down, standing up against the trash can, pushing up and quickly pushing a letter key to enter the command while Laura is displaying a walking frame.

I've attached a ScummVM save game of the DOS version using the nightly build.

Attachments (2)

laurabow.007 (23.3 KB ) - added by sluicebox 2 years ago.
bottle_freeze.png (16.6 KB ) - added by sluicebox 2 years ago.

Download all attachments as: .zip

Change History (5)

by sluicebox, 2 years ago

Attachment: laurabow.007 added

by sluicebox, 2 years ago

Attachment: bottle_freeze.png added

comment:1 by sluicebox, 12 months ago

This is a symptom of a larger bug I've since written up and fixed: #10733

comment:2 by digitall, 12 months ago

Keywords: has-pull-request added

comment:3 by digitall, 12 months ago

Owner: set to bluegr
Resolution: fixed
Status: newclosed

Since ​https://github.com/scummvm/scummvm/pull/1353 has been merged, this can now be closed.

Closing as fixed.

Note: See TracTickets for help on using tickets.