Opened 16 years ago

Closed 15 years ago

Last modified 15 years ago

#990 closed defect (fixed)

LOOM: Gltiches caused by empty talk strings

Reported by: SF/dfabulich Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Loom

Description

In the attached save, click in the middle of the room
and wait for the scene to finish or just hit escape.
After the scene is over, you'll move your mouth as if
delivering a line. This happens sporadically
throughout the game; this was just a convenient
reproduction point.

Win2K, ScummVM 0.5.0pre-cvs Built on Jul 10 2003 20:29:19.

Ticket imported from: #770049. Ticket imported from: bugs/990.

Attachments (1)

loom.s03 (57.8 KB) - added by SF/dfabulich 16 years ago.
Saved game right in front of Stoke

Download all attachments as: .zip

Change History (11)

Changed 16 years ago by SF/dfabulich

Attachment: loom.s03 added

Saved game right in front of Stoke

comment:1 Changed 16 years ago by fingolfin

Summary: Loom EGA: After some cutscenes, Bobbin moves his mouthLOOM: After some cutscenes, Bobbin moves his mouth

comment:2 Changed 16 years ago by fingolfin

Maybe he's muttering something under his breath? :-) ("idiot")

Seriously, though, have you verified that this doesn't also happen
in the original?

This cutscene is controlled by script 86. Near the end, it contains
this (which causes the mouth movement):
[052B] (14) print(1,[Center(),Pos(160,Var[166]),Text("")]);

Maybe actorTalk should do nothing for empty talk strings?

comment:3 Changed 16 years ago by Kirben

The problem is specific to ScummVM and doesn't occur in the
original Loom [ega].

comment:4 Changed 15 years ago by Kirben

fingolfin:
I think that change would be correct, it might also help the
other current Loom bug.
I noticed Bobin talks after introduction too, where another
script has a similar print line.
If you could create patch, I can play through game to check
for any possible problems.

comment:5 Changed 15 years ago by Kirben

I checked scripts and the 'distaff sporadically loses bits issue'
(#770039) is also caused by these empty talk strings.

comment:6 Changed 15 years ago by Kirben

Summary: LOOM: After some cutscenes, Bobbin moves his mouthLOOM: Gltiches caused by empty talk strings

comment:7 Changed 15 years ago by fingolfin

Owner: set to fingolfin

comment:8 Changed 15 years ago by fingolfin

I put a workaround for this into CVS, please test it. I am not sure
if it is also needed for LoomCD, if so, feel free to add
GID_LOOM256 to the test used by the workaround.

comment:9 Changed 15 years ago by Kirben

The work around you added solves the problem.
The work around is needed for LoomCD too, since bug
#770039 effected both games.

comment:10 Changed 15 years ago by Kirben

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.