Opened 2 years ago

Closed 2 years ago

#9899 closed defect (fixed)

TITANIC: Turned on fan Looks off

Reported by: dafioram Owned by: dreammaster
Priority: low Component: Engine: Titanic
Keywords: Cc:
Game: Starship Titanic

Description

ScummVM: 1.10.0git-3571-gd5ebd9a 64bit
Game: Starship Titanic, GOG (1.00.42c), Windows/English
Tester OS: Win7-64

If you turn the fan on to any other speed other than just ON the meter will show the speed as being OFF. It works just fine though.

Attachments (1)

titanic-win.042 (108.3 KB ) - added by dafioram 2 years ago.
save

Download all attachments as: .zip

Change History (4)

by dafioram, 2 years ago

Attachment: titanic-win.042 added

save

comment:1 by dreammaster, 2 years ago

Owner: set to dreammaster
Resolution: outdated
Status: newclosed

Looks fine in the latest master. At a guess, I'd say my recent graphic fixes have fixed it as well.

comment:2 by dafioram, 2 years ago

Resolution: outdated
Status: closednew

This is still present in 1.10.0git-4073-g2005ed7. It only happens if the fan is set to slow and I look away and look back. For other settings it works as intended.

Demo: https://streamable.com/gx242

The right video is scummvm and it shows the fan off even though it is on at the end.

If you set the fan to fast and look away and look back it will "look" slow.
So the slow fan setting looks off and the fast setting looks slow if you look away and look back.

comment:3 by dreammaster, 2 years ago

Resolution: fixed
Status: newclosed

Ah, now I understand. Fixed.

Note: See TracTickets for help on using tickets.